aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-08-15 22:45:44 +0000
committerChristian Grothoff <christian@grothoff.org>2012-08-15 22:45:44 +0000
commitc9d47aa8945fbccfd26101f8c015f5b6b267d006 (patch)
tree81234cd42d0232c7aafecae20907a8d04a1c3530 /src/plugins/Makefile.am
parent27dc2404bfa0dee7bddb972bdfa03de17ea6eb4b (diff)
downloadlibextractor-c9d47aa8945fbccfd26101f8c015f5b6b267d006.tar.gz
libextractor-c9d47aa8945fbccfd26101f8c015f5b6b267d006.zip
implementing tiff support
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index fdfbd18..3e0f60a 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -35,7 +35,8 @@ EXTRA_DIST = template_extractor.c \
35 testdata/deb_bzip2.deb \ 35 testdata/deb_bzip2.deb \
36 testdata/nsf_arkanoid.nsf \ 36 testdata/nsf_arkanoid.nsf \
37 testdata/nsfe_classics.nsfe \ 37 testdata/nsfe_classics.nsfe \
38 testdata/xm_diesel.xm 38 testdata/xm_diesel.xm \
39 testdata/tiff_haute.tiff
39 40
40if HAVE_VORBISFILE 41if HAVE_VORBISFILE
41PLUGIN_OGG=libextractor_ogg.la 42PLUGIN_OGG=libextractor_ogg.la
@@ -68,6 +69,11 @@ PLUGIN_FLAC=libextractor_flac.la
68TEST_FLAC=test_flac 69TEST_FLAC=test_flac
69endif 70endif
70 71
72if HAVE_TIFF
73PLUGIN_TIFF=libextractor_tiff.la
74TEST_TIFF=test_tiff
75endif
76
71if HAVE_MPEG2 77if HAVE_MPEG2
72PLUGIN_MPEG=libextractor_mpeg.la 78PLUGIN_MPEG=libextractor_mpeg.la
73TEST_MPEG=test_mpeg 79TEST_MPEG=test_mpeg
@@ -108,6 +114,7 @@ plugin_LTLIBRARIES = \
108 $(PLUGIN_ZLIB) \ 114 $(PLUGIN_ZLIB) \
109 $(PLUGIN_OGG) \ 115 $(PLUGIN_OGG) \
110 $(PLUGIN_MIME) \ 116 $(PLUGIN_MIME) \
117 $(PLUGIN_TIFF) \
111 $(PLUGIN_GIF) \ 118 $(PLUGIN_GIF) \
112 $(PLUGIN_RPM) \ 119 $(PLUGIN_RPM) \
113 $(PLUGIN_FLAC) \ 120 $(PLUGIN_FLAC) \
@@ -134,6 +141,7 @@ check_PROGRAMS = \
134 $(TEST_GTK) \ 141 $(TEST_GTK) \
135 $(TEST_OGG) \ 142 $(TEST_OGG) \
136 $(TEST_MIME) \ 143 $(TEST_MIME) \
144 $(TEST_TIFF) \
137 $(TEST_GIF) \ 145 $(TEST_GIF) \
138 $(TEST_RPM) \ 146 $(TEST_RPM) \
139 $(TEST_FLAC) \ 147 $(TEST_FLAC) \
@@ -397,6 +405,19 @@ test_exiv2_LDADD = \
397 $(top_builddir)/src/plugins/libtest.la 405 $(top_builddir)/src/plugins/libtest.la
398 406
399 407
408libextractor_tiff_la_SOURCES = \
409 tiff_extractor.c
410libextractor_tiff_la_LDFLAGS = \
411 $(PLUGINFLAGS)
412libextractor_tiff_la_LIBADD = \
413 -ltiff
414
415test_tiff_SOURCES = \
416 test_tiff.c
417test_tiff_LDADD = \
418 $(top_builddir)/src/plugins/libtest.la
419
420
400libextractor_ole2_la_SOURCES = \ 421libextractor_ole2_la_SOURCES = \
401 ole2_extractor.c 422 ole2_extractor.c
402libextractor_ole2_la_CFLAGS = \ 423libextractor_ole2_la_CFLAGS = \