aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e5a880e..9101b16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -672,13 +672,11 @@ if test x$ffmpeg_enabled = x1
672then 672then
673 ffmpeg_enabled=0 673 ffmpeg_enabled=0
674 new_ffmpeg=0 674 new_ffmpeg=0
675 AC_CHECK_HEADERS([libavutil/frame.h], 675 AC_CHECK_HEADERS([libavutil/frame.h],new_ffmpeg=1)
676 AC_CHECK_HEADERS([libavresample/avresample.h],new_ffmpeg=1))
677
678 AC_CHECK_LIB(swscale, sws_getContext, 676 AC_CHECK_LIB(swscale, sws_getContext,
679 AC_CHECK_LIB(avcodec, avcodec_alloc_context3, 677 AC_CHECK_LIB(avcodec, avcodec_alloc_context3,
680 ffmpeg_enabled=1)) 678 ffmpeg_enabled=1))
681 AC_CHECK_HEADERS([libavutil/avutil.h ffmpeg/avutil.h libavformat/avformat.h ffmpeg/avformat.h libavcodec/avcodec.h ffmpeg/avcodec.h libswscale/swscale.h ffmpeg/swscale.h]) 679 AC_CHECK_HEADERS([libavutil/avutil.h ffmpeg/avutil.h libavformat/avformat.h ffmpeg/avformat.h libavcodec/avcodec.h ffmpeg/avcodec.h libswscale/swscale.h ffmpeg/swscale.h libavresample/avresample.h ffmpeg/avresample.h])
682fi 680fi
683AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0) 681AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
684AM_CONDITIONAL(HAVE_FFMPEG_NEW, test x$new_ffmpeg != x0) 682AM_CONDITIONAL(HAVE_FFMPEG_NEW, test x$new_ffmpeg != x0)
@@ -807,7 +805,7 @@ fi
807 805
808if test "x$new_ffmpeg" = "x0" 806if test "x$new_ffmpeg" = "x0"
809then 807then
810 AC_MSG_NOTICE([NOTICE: FFmpeg/opus audio preview plugin disabled, It needs libav > 10, or a FFmpeg with --enable-libavresample]) 808 AC_MSG_NOTICE([NOTICE: FFmpeg/opus audio preview plugin disabled])
811fi 809fi
812 810
813if test "x$without_gtk" = "xtrue" 811if test "x$without_gtk" = "xtrue"