aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 39 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5d8a134..026af0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -412,15 +412,51 @@ fi
412 412
413# check for gtk >= 2.6.0 413# check for gtk >= 2.6.0
414AC_MSG_CHECKING(for gtk) 414AC_MSG_CHECKING(for gtk)
415AM_PATH_GTK_2_0(2.6.0,without_gtk=false,without_gtk=true) 415check_for_3=3.0.0
416check_for_2=false
417AC_ARG_WITH(gtk_version,
418 [ --with-gtk-version=VERSION version number of gtk to use (>=3.0.0 by default)],
419 [AC_MSG_RESULT([$with_gtk_version])
420 case $with_gtk_version in
421 *)
422 if test "x${with_gtk_version:0:1}" == "x2"
423 then
424 check_for_3=false
425 check_for_2=$with_gtk_version
426 elif test "x${with_gtk_version:0:1}" == "x3"
427 then
428 check_for_3=$with_gtk_version
429 check_for_2=false
430 fi
431 ;;
432 esac
433 ],
434 [AC_MSG_RESULT([--with-gtk-version not specified])])
435
436without_gtk=false
437if test "x$check_for_3" != "xfalse"
438then
439 AM_PATH_GTK_3_0([$check_for_3],without_gtk=false,)
440fi
441
442if test "x$without_gtk" == "xfalse" -a "x$check_for_2" != "xfalse"
443then
444 AM_PATH_GTK_2_0([$check_for_2],without_gtk=false,)
445fi
446
416AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue) 447AM_CONDITIONAL(HAVE_GTK, test x$without_gtk != xtrue)
417if test $without_gtk != true 448if test $without_gtk != true
418then 449then
419 AC_DEFINE_UNQUOTED([HAVE_GTK], 1, [We have GTK]) 450 AC_DEFINE_UNQUOTED([HAVE_GTK], 1, [We have GTK])
420else 451else
421 AM_CONDITIONAL(HAVE_GTK,false) 452 AC_MSG_ERROR(Cannot find GTK: Is pkg-config in path?)
422fi 453fi
423 454
455CFLAGS="$CFLAGS $GTK_CFLAGS"
456CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
457LIBS="$LIBS $GTK_LIBS"
458
459
424AC_ARG_WITH([gstreamer], AS_HELP_STRING([--with-gstreamer], [Build with the GStreamer plugin]), [], [with_gstreamer=yes]) 460AC_ARG_WITH([gstreamer], AS_HELP_STRING([--with-gstreamer], [Build with the GStreamer plugin]), [], [with_gstreamer=yes])
425 461
426have_gstreamer=no 462have_gstreamer=no