aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 8005a39..80ce414 100644
--- a/configure.ac
+++ b/configure.ac
@@ -648,32 +648,6 @@ CPPFLAGS="$CPPFLAGS_OLD"
648AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0) 648AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0)
649AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF) 649AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF)
650 650
651AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor])
652new_ffmpeg=0
653AC_ARG_ENABLE(ffmpeg,
654 [AC_HELP_STRING([--enable-ffmpeg],[Enable FFmpeg support])
655 AC_HELP_STRING([--disable-ffmpeg],[Disable FFmpeg support])],
656 [AS_CASE(["$enableval"],
657 [no],[
658 AC_MSG_RESULT(no)
659 ffmpeg_enabled=0
660 ],[
661 AC_MSG_RESULT(yes)
662 ffmpeg_enabled=1
663 ])],
664 [ AC_MSG_RESULT(yes)
665 ffmpeg_enabled=1])
666AS_IF([test x$ffmpeg_enabled = x1],
667 [ffmpeg_enabled=0
668 new_ffmpeg=0
669 AC_CHECK_HEADERS([libavutil/avutil.h libavformat/avformat.h libavcodec/avcodec.h libavutil/frame.h],
670 AC_CHECK_HEADERS([libswresample/swresample.h],
671 AC_CHECK_LIB(avutil, av_audio_fifo_alloc,
672 ffmpeg_enabled=1)))
673 ])
674AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
675
676
677LE_INTLINCL="" 651LE_INTLINCL=""
678LE_LIBINTL="$LTLIBINTL" 652LE_LIBINTL="$LTLIBINTL"
679AC_ARG_ENABLE(framework, [ --enable-framework enable Mac OS X framework build helpers],enable_framework_build=$enableval) 653AC_ARG_ENABLE(framework, [ --enable-framework enable Mac OS X framework build helpers],enable_framework_build=$enableval)
@@ -769,9 +743,6 @@ AS_IF([test "x$HAVE_GIF_TRUE" = "x#"],
769AS_IF([test "x$have_gsf" != "xtrue"], 743AS_IF([test "x$have_gsf" != "xtrue"],
770 [AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])]) 744 [AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])])
771 745
772AS_IF([test "x$ffmpeg_enabled" = "x0"],
773 [AC_MSG_NOTICE([NOTICE: FFmpeg/opus audito thumbnailer plugin disabled])])
774
775AS_IF([test "x$have_gdk_pixbuf" = "x0"], 746AS_IF([test "x$have_gdk_pixbuf" = "x0"],
776 [AC_MSG_NOTICE([NOTICE: libgdk-pixbuf not found, gtk thumbnail support disabled])]) 747 [AC_MSG_NOTICE([NOTICE: libgdk-pixbuf not found, gtk thumbnail support disabled])])
777 748