summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 8005a39..80ce414 100644
--- a/configure.ac
+++ b/configure.ac
@@ -648,32 +648,6 @@ CPPFLAGS="$CPPFLAGS_OLD"
AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0)
AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF)
-AC_MSG_CHECKING([whether to enable the FFmpeg thumbnail extractor])
-new_ffmpeg=0
-AC_ARG_ENABLE(ffmpeg,
- [AC_HELP_STRING([--enable-ffmpeg],[Enable FFmpeg support])
- AC_HELP_STRING([--disable-ffmpeg],[Disable FFmpeg support])],
- [AS_CASE(["$enableval"],
- [no],[
- AC_MSG_RESULT(no)
- ffmpeg_enabled=0
- ],[
- AC_MSG_RESULT(yes)
- ffmpeg_enabled=1
- ])],
- [ AC_MSG_RESULT(yes)
- ffmpeg_enabled=1])
-AS_IF([test x$ffmpeg_enabled = x1],
- [ffmpeg_enabled=0
- new_ffmpeg=0
- AC_CHECK_HEADERS([libavutil/avutil.h libavformat/avformat.h libavcodec/avcodec.h libavutil/frame.h],
- AC_CHECK_HEADERS([libswresample/swresample.h],
- AC_CHECK_LIB(avutil, av_audio_fifo_alloc,
- ffmpeg_enabled=1)))
- ])
-AM_CONDITIONAL(HAVE_FFMPEG, test x$ffmpeg_enabled != x0)
-
-
LE_INTLINCL=""
LE_LIBINTL="$LTLIBINTL"
AC_ARG_ENABLE(framework, [ --enable-framework enable Mac OS X framework build helpers],enable_framework_build=$enableval)
@@ -769,9 +743,6 @@ AS_IF([test "x$HAVE_GIF_TRUE" = "x#"],
AS_IF([test "x$have_gsf" != "xtrue"],
[AC_MSG_NOTICE([NOTICE: libgsf not found, no OLE2 (MS Office) support])])
-AS_IF([test "x$ffmpeg_enabled" = "x0"],
- [AC_MSG_NOTICE([NOTICE: FFmpeg/opus audito thumbnailer plugin disabled])])
-
AS_IF([test "x$have_gdk_pixbuf" = "x0"],
[AC_MSG_NOTICE([NOTICE: libgdk-pixbuf not found, gtk thumbnail support disabled])])