aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 625a1fd..ae1bd5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,6 +282,17 @@ fi
282 282
283# restore LIBS 283# restore LIBS
284LIBS=$LIBSOLD 284LIBS=$LIBSOLD
285
286# check for apparmor
287AC_CHECK_LIB(apparmor, aa_change_profile,
288 [AC_CHECK_HEADERS([sys/apparmor.h],
289 AM_CONDITIONAL(HAVE_APPARMOR, true)
290 AC_DEFINE(HAVE_APPARMOR,1,[Have apparmor]),
291 AM_CONDITIONAL(HAVE_APPARMOR, false)
292 AC_DEFINE(HAVE_APPARMOR,0,[lacking apparmor]))],
293 AM_CONDITIONAL(HAVE_APPARMOR, false),
294 -lapparmor)
295
285# FIXME: allow --with-oggvorbis=PFX 296# FIXME: allow --with-oggvorbis=PFX
286 297
287# test if we have vorbisfile 298# test if we have vorbisfile
@@ -846,3 +857,8 @@ fi
846else 857else
847 AC_MSG_NOTICE([NOTICE: gstreamer not found, gstreamer support disabled]) 858 AC_MSG_NOTICE([NOTICE: gstreamer not found, gstreamer support disabled])
848fi 859fi
860
861if test "x$HAVE_APPARMOR_TRUE" = "x#"
862then
863 AC_MSG_NOTICE([NOTICE: libapparmor not found, apparmor support disabled])
864fi