aboutsummaryrefslogtreecommitdiff
path: root/src/main/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/Makefile.am')
-rw-r--r--src/main/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/main/Makefile.am b/src/main/Makefile.am
index 4508097..3db2e69 100644
--- a/src/main/Makefile.am
+++ b/src/main/Makefile.am
@@ -19,10 +19,12 @@ extract_LDADD = \
19 $(top_builddir)/src/main/libextractor.la 19 $(top_builddir)/src/main/libextractor.la
20 20
21if HAVE_ZLIB 21if HAVE_ZLIB
22 zlib =-lz 22zlib =-lz
23TEST_ZLIB = test_gzip
23endif 24endif
24if HAVE_BZ2 25if HAVE_BZ2
25 bz2lib = -lbz2 26bz2lib = -lbz2
27TEST_BZIP2 = test_bzip2
26endif 28endif
27 29
28libextractor_la_LDFLAGS = \ 30libextractor_la_LDFLAGS = \
@@ -99,8 +101,8 @@ check_PROGRAMS = \
99 test_plugin_load_multi \ 101 test_plugin_load_multi \
100 test_ipc \ 102 test_ipc \
101 test_file \ 103 test_file \
102 test_gzip \ 104 $(TEST_ZLIB) \
103 test_bzip2 105 $(TEST_BZIP2)
104 106
105if ENABLE_TEST_RUN 107if ENABLE_TEST_RUN
106TESTS = $(check_PROGRAMS) 108TESTS = $(check_PROGRAMS)