aboutsummaryrefslogtreecommitdiff
path: root/src/main/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/Makefile.am')
-rw-r--r--src/main/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/main/Makefile.am b/src/main/Makefile.am
index d5245f9..4577ae0 100644
--- a/src/main/Makefile.am
+++ b/src/main/Makefile.am
@@ -42,7 +42,10 @@ endif
42PLUGINFLAGS = $(makesymbolic) $(LE_PLUGIN_LDFLAGS) 42PLUGINFLAGS = $(makesymbolic) $(LE_PLUGIN_LDFLAGS)
43 43
44EXTRA_DIST = \ 44EXTRA_DIST = \
45 iconv.c fuzz_default.sh fuzz_thumbnail.sh 45 iconv.c fuzz_default.sh fuzz_thumbnail.sh \
46 test_file.dat \
47 test_file.dat.gz \
48 test_file.dat.bz2
46 49
47libextractor_la_CPPFLAGS = -DPLUGINDIR=\"@RPLUGINDIR@\" -DPLUGININSTDIR=\"${plugindir}\" $(AM_CPPFLAGS) 50libextractor_la_CPPFLAGS = -DPLUGINDIR=\"@RPLUGINDIR@\" -DPLUGININSTDIR=\"${plugindir}\" $(AM_CPPFLAGS)
48 51
@@ -85,7 +88,9 @@ check_PROGRAMS = \
85 test_plugin_loading \ 88 test_plugin_loading \
86 test_plugin_load_multi \ 89 test_plugin_load_multi \
87 test_ipc \ 90 test_ipc \
88 test_file 91 test_file \
92 test_gzip \
93 test_bzip2
89 94
90TESTS = $(check_PROGRAMS) 95TESTS = $(check_PROGRAMS)
91 96
@@ -104,3 +109,9 @@ test_ipc_SOURCES = \
104test_file_SOURCES = \ 109test_file_SOURCES = \
105 test_file.c 110 test_file.c
106 111
112test_gzip_SOURCES = \
113 test_gzip.c
114
115test_bzip2_SOURCES = \
116 test_bzip2.c
117