aboutsummaryrefslogtreecommitdiff
path: root/src/main/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/Makefile.am')
-rw-r--r--src/main/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/main/Makefile.am b/src/main/Makefile.am
index 2d32ca6..33acdf7 100644
--- a/src/main/Makefile.am
+++ b/src/main/Makefile.am
@@ -56,12 +56,23 @@ extract_SOURCES = \
56 getopt.c getopt.h getopt1.c 56 getopt.c getopt.h getopt1.c
57 57
58 58
59
59LDADD = \ 60LDADD = \
60 $(top_builddir)/src/main/libextractor.la 61 $(top_builddir)/src/main/libextractor.la
61 62
62TESTS_ENVIRONMENT = testdatadir=$(top_srcdir)/test 63TESTS_ENVIRONMENT = testdatadir=$(top_srcdir)/test
63TESTS_ENVIRONMENT += bindir=${bindir} 64TESTS_ENVIRONMENT += bindir=${bindir}
64 65
66noinst_LTLIBRARIES = \
67 libextractor_test.la
68
69libextractor_test_la_SOURCES = \
70 test_extractor.c
71libextractor_test_la_LDFLAGS = \
72 $(PLUGINFLAGS)
73libextractor_test_la_LIBADD = \
74 $(LE_LIBINTL)
75
65check_PROGRAMS = \ 76check_PROGRAMS = \
66 test_trivial \ 77 test_trivial \
67 test_plugin_loading \ 78 test_plugin_loading \