aboutsummaryrefslogtreecommitdiff
path: root/src/main/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/Makefile.am')
-rw-r--r--src/main/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/main/Makefile.am b/src/main/Makefile.am
index f9bec0a..d793a31 100644
--- a/src/main/Makefile.am
+++ b/src/main/Makefile.am
@@ -2,8 +2,9 @@ SUBDIRS = .
2 2
3INCLUDES = -I$(top_srcdir)/src/include $(LTDLINCL) 3INCLUDES = -I$(top_srcdir)/src/include $(LTDLINCL)
4 4
5# install plugins under: 5# install test plugins under /tmp (we must install them somewhere,
6plugindir = $(libdir)/@RPLUGINDIR@ 6# with 'noinst' automake insists on building a static library...)
7tmpdir = /tmp/
7 8
8LIBS = \ 9LIBS = \
9 @LE_LIBINTL@ @LE_LIB_LIBS@ 10 @LE_LIBINTL@ @LE_LIB_LIBS@
@@ -34,6 +35,12 @@ else
34EXTRACTOR_IPC=extractor_ipc_gnu.c 35EXTRACTOR_IPC=extractor_ipc_gnu.c
35endif 36endif
36 37
38if HAVE_GNU_LD
39 makesymbolic=-Wl,-Bsymbolic
40endif
41
42PLUGINFLAGS = $(makesymbolic) $(LE_PLUGIN_LDFLAGS)
43
37EXTRA_DIST = \ 44EXTRA_DIST = \
38 iconv.c fuzz_default.sh fuzz_thumbnail.sh 45 iconv.c fuzz_default.sh fuzz_thumbnail.sh
39 46
@@ -63,7 +70,7 @@ LDADD = \
63TESTS_ENVIRONMENT = testdatadir=$(top_srcdir)/test 70TESTS_ENVIRONMENT = testdatadir=$(top_srcdir)/test
64TESTS_ENVIRONMENT += bindir=${bindir} 71TESTS_ENVIRONMENT += bindir=${bindir}
65 72
66noinst_LTLIBRARIES = \ 73tmp_LTLIBRARIES = \
67 libextractor_test.la 74 libextractor_test.la
68 75
69libextractor_test_la_SOURCES = \ 76libextractor_test_la_SOURCES = \
@@ -77,7 +84,7 @@ check_PROGRAMS = \
77 test_trivial \ 84 test_trivial \
78 test_plugin_loading \ 85 test_plugin_loading \
79 test_plugin_load_multi \ 86 test_plugin_load_multi \
80 test_ipc 87 test_ipc
81 88
82TESTS = $(check_PROGRAMS) 89TESTS = $(check_PROGRAMS)
83 90