aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index ee0184d..91f8d6b 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -89,6 +89,7 @@ plugin_LTLIBRARIES = \
89 $(pdf) \ 89 $(pdf) \
90 libextractor_png.la \ 90 libextractor_png.la \
91 libextractor_ps.la \ 91 libextractor_ps.la \
92 libextractor_qt.la \
92 libextractor_real.la \ 93 libextractor_real.la \
93 $(rpm) \ 94 $(rpm) \
94 libextractor_tar.la \ 95 libextractor_tar.la \
@@ -249,6 +250,13 @@ libextractor_ps_la_SOURCES = \
249libextractor_ps_la_LDFLAGS = \ 250libextractor_ps_la_LDFLAGS = \
250 $(PLUGINFLAGS) 251 $(PLUGINFLAGS)
251 252
253libextractor_qt_la_SOURCES = \
254 qt_extractor.c
255libextractor_qt_la_LDFLAGS = \
256 $(PLUGINFLAGS)
257libextractor_qt_la_LIBADD = \
258 -lz -lm
259
252libextractor_real_la_SOURCES = \ 260libextractor_real_la_SOURCES = \
253 real_extractor.c 261 real_extractor.c
254libextractor_real_la_LDFLAGS = \ 262libextractor_real_la_LDFLAGS = \
@@ -303,7 +311,6 @@ OLD_LIBS = \
303 $(extrampeg) \ 311 $(extrampeg) \
304 libextractor_nsf.la \ 312 libextractor_nsf.la \
305 libextractor_nsfe.la \ 313 libextractor_nsfe.la \
306 $(extraqt) \
307 libextractor_riff.la \ 314 libextractor_riff.la \
308 libextractor_s3m.la \ 315 libextractor_s3m.la \
309 libextractor_sid.la \ 316 libextractor_sid.la \
@@ -313,15 +320,6 @@ OLD_LIBS = \
313 libextractor_xm.la \ 320 libextractor_xm.la \
314 libextractor_zip.la 321 libextractor_zip.la
315 322
316if HAVE_ZLIB
317libextractor_qt_la_SOURCES = \
318 qtextractor.c
319libextractor_qt_la_LDFLAGS = \
320 $(PLUGINFLAGS)
321libextractor_qt_la_LIBADD = \
322 -lz
323endif
324
325 323
326libextractor_id3v2_la_SOURCES = \ 324libextractor_id3v2_la_SOURCES = \
327 id3v2extractor.c 325 id3v2extractor.c