aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 281035c..fb91ddb 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -34,7 +34,8 @@ EXTRA_DIST = template_extractor.c \
34 testdata/odf_cg.odt \ 34 testdata/odf_cg.odt \
35 testdata/deb_bzip2.deb \ 35 testdata/deb_bzip2.deb \
36 testdata/nsf_arkanoid.nsf \ 36 testdata/nsf_arkanoid.nsf \
37 testdata/nsfe_classics.nsfe 37 testdata/nsfe_classics.nsfe \
38 testdata/xm_diesel.xm
38 39
39if HAVE_VORBISFILE 40if HAVE_VORBISFILE
40PLUGIN_OGG=libextractor_ogg.la 41PLUGIN_OGG=libextractor_ogg.la
@@ -119,6 +120,7 @@ check_PROGRAMS = \
119 test_png \ 120 test_png \
120 test_odf \ 121 test_odf \
121 test_zip \ 122 test_zip \
123 test_xm \
122 test_nsf \ 124 test_nsf \
123 test_nsfe \ 125 test_nsfe \
124 $(TEST_ZLIB) \ 126 $(TEST_ZLIB) \
@@ -151,6 +153,11 @@ libextractor_xm_la_SOURCES = \
151libextractor_xm_la_LDFLAGS = \ 153libextractor_xm_la_LDFLAGS = \
152 $(PLUGINFLAGS) 154 $(PLUGINFLAGS)
153 155
156test_xm_SOURCES = \
157 test_xm.c
158test_xm_LDADD = \
159 $(top_builddir)/src/plugins/libtest.la
160
154 161
155libextractor_deb_la_SOURCES = \ 162libextractor_deb_la_SOURCES = \
156 deb_extractor.c 163 deb_extractor.c
@@ -240,6 +247,7 @@ libextractor_sid_la_SOURCES = \
240libextractor_sid_la_LDFLAGS = \ 247libextractor_sid_la_LDFLAGS = \
241 $(PLUGINFLAGS) 248 $(PLUGINFLAGS)
242 249
250
243libextractor_s3m_la_SOURCES = \ 251libextractor_s3m_la_SOURCES = \
244 s3m_extractor.c 252 s3m_extractor.c
245libextractor_s3m_la_LDFLAGS = \ 253libextractor_s3m_la_LDFLAGS = \