aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 9cc8f90..07b0560 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -29,7 +29,8 @@ EXTRA_DIST = template_extractor.c \
29 testdata/ole2_msword.doc \ 29 testdata/ole2_msword.doc \
30 testdata/ole2_starwriter40.sdw \ 30 testdata/ole2_starwriter40.sdw \
31 testdata/ole2_blair.doc \ 31 testdata/ole2_blair.doc \
32 testdata/ole2_excel.xls 32 testdata/ole2_excel.xls \
33 testdata/png_image.png
33 34
34if HAVE_VORBISFILE 35if HAVE_VORBISFILE
35PLUGIN_OGG=libextractor_ogg.la 36PLUGIN_OGG=libextractor_ogg.la
@@ -79,6 +80,7 @@ endif
79 80
80plugin_LTLIBRARIES = \ 81plugin_LTLIBRARIES = \
81 libextractor_it.la \ 82 libextractor_it.la \
83 libextractor_png.la \
82 libextractor_xm.la \ 84 libextractor_xm.la \
83 libextractor_s3m.la \ 85 libextractor_s3m.la \
84 libextractor_wav.la \ 86 libextractor_wav.la \
@@ -100,6 +102,7 @@ check_PROGRAMS = \
100 test_wav \ 102 test_wav \
101 test_it \ 103 test_it \
102 test_s3m \ 104 test_s3m \
105 test_png \
103 $(TEST_OGG) \ 106 $(TEST_OGG) \
104 $(TEST_MIME) \ 107 $(TEST_MIME) \
105 $(TEST_GIF) \ 108 $(TEST_GIF) \
@@ -130,6 +133,19 @@ libextractor_xm_la_LDFLAGS = \
130 $(PLUGINFLAGS) 133 $(PLUGINFLAGS)
131 134
132 135
136libextractor_png_la_SOURCES = \
137 png_extractor.c
138libextractor_png_la_LDFLAGS = \
139 $(PLUGINFLAGS)
140libextractor_png_la_LIBADD = \
141 $(top_builddir)/src/common/libextractor_common.la
142
143test_png_SOURCES = \
144 test_png.c
145test_png_LDADD = \
146 $(top_builddir)/src/plugins/libtest.la
147
148
133libextractor_it_la_SOURCES = \ 149libextractor_it_la_SOURCES = \
134 it_extractor.c 150 it_extractor.c
135libextractor_it_la_LDFLAGS = \ 151libextractor_it_la_LDFLAGS = \