aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 4669a11..281035c 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -33,7 +33,8 @@ EXTRA_DIST = template_extractor.c \
33 testdata/png_image.png \ 33 testdata/png_image.png \
34 testdata/odf_cg.odt \ 34 testdata/odf_cg.odt \
35 testdata/deb_bzip2.deb \ 35 testdata/deb_bzip2.deb \
36 testdata/nsf_arkanoid.nsf 36 testdata/nsf_arkanoid.nsf \
37 testdata/nsfe_classics.nsfe
37 38
38if HAVE_VORBISFILE 39if HAVE_VORBISFILE
39PLUGIN_OGG=libextractor_ogg.la 40PLUGIN_OGG=libextractor_ogg.la
@@ -119,6 +120,7 @@ check_PROGRAMS = \
119 test_odf \ 120 test_odf \
120 test_zip \ 121 test_zip \
121 test_nsf \ 122 test_nsf \
123 test_nsfe \
122 $(TEST_ZLIB) \ 124 $(TEST_ZLIB) \
123 $(TEST_OGG) \ 125 $(TEST_OGG) \
124 $(TEST_MIME) \ 126 $(TEST_MIME) \
@@ -177,6 +179,11 @@ libextractor_nsfe_la_SOURCES = \
177libextractor_nsfe_la_LDFLAGS = \ 179libextractor_nsfe_la_LDFLAGS = \
178 $(PLUGINFLAGS) 180 $(PLUGINFLAGS)
179 181
182test_nsfe_SOURCES = \
183 test_nsfe.c
184test_nsfe_LDADD = \
185 $(top_builddir)/src/plugins/libtest.la
186
180 187
181libextractor_odf_la_SOURCES = \ 188libextractor_odf_la_SOURCES = \
182 odf_extractor.c 189 odf_extractor.c