aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 8cbe21a..58b0590 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -23,7 +23,9 @@ SUBDIRS = .
23EXTRA_DIST = \ 23EXTRA_DIST = \
24 fuzz_default.sh \ 24 fuzz_default.sh \
25 template_extractor.c \ 25 template_extractor.c \
26 testdata/audiosig.rm \
26 testdata/archive_test.tar \ 27 testdata/archive_test.tar \
28 testdata/chello-elf \
27 testdata/deb_bzip2.deb \ 29 testdata/deb_bzip2.deb \
28 testdata/dvi_ora.dvi \ 30 testdata/dvi_ora.dvi \
29 testdata/exiv2_iptc.jpg \ 31 testdata/exiv2_iptc.jpg \
@@ -51,6 +53,7 @@ EXTRA_DIST = \
51 testdata/png_image.png \ 53 testdata/png_image.png \
52 testdata/ps_bloomfilter.ps \ 54 testdata/ps_bloomfilter.ps \
53 testdata/ps_wallace.ps \ 55 testdata/ps_wallace.ps \
56 testdata/ra3.ra \
54 testdata/riff_flame.avi \ 57 testdata/riff_flame.avi \
55 testdata/rpm_test.rpm \ 58 testdata/rpm_test.rpm \
56 testdata/s3m_2nd_pm.s3m \ 59 testdata/s3m_2nd_pm.s3m \
@@ -171,6 +174,7 @@ plugin_LTLIBRARIES = \
171 libextractor_nsf.la \ 174 libextractor_nsf.la \
172 libextractor_nsfe.la \ 175 libextractor_nsfe.la \
173 libextractor_ps.la \ 176 libextractor_ps.la \
177 libextractor_real.la \
174 libextractor_riff.la \ 178 libextractor_riff.la \
175 libextractor_s3m.la \ 179 libextractor_s3m.la \
176 libextractor_sid.la \ 180 libextractor_sid.la \
@@ -209,6 +213,7 @@ check_PROGRAMS = \
209 test_odf \ 213 test_odf \
210 test_ps \ 214 test_ps \
211 test_png \ 215 test_png \
216 test_real \
212 test_riff \ 217 test_riff \
213 test_s3m \ 218 test_s3m \
214 test_sid \ 219 test_sid \
@@ -562,6 +567,20 @@ test_ps_LDADD = \
562 $(top_builddir)/src/plugins/libtest.la 567 $(top_builddir)/src/plugins/libtest.la
563 568
564 569
570libextractor_real_la_SOURCES = \
571 real_extractor.c
572libextractor_real_la_LDFLAGS = \
573 $(PLUGINFLAGS)
574libextractor_real_la_LIBADD = \
575 -lm \
576 $(XLIB) \
577 $(LE_LIBINTL)
578
579test_real_SOURCES = \
580 test_real.c
581test_real_LDADD = \
582 $(top_builddir)/src/plugins/libtest.la
583
565libextractor_riff_la_SOURCES = \ 584libextractor_riff_la_SOURCES = \
566 riff_extractor.c 585 riff_extractor.c
567libextractor_riff_la_LDFLAGS = \ 586libextractor_riff_la_LDFLAGS = \
@@ -643,6 +662,15 @@ test_tiff_LDADD = \
643 $(top_builddir)/src/plugins/libtest.la 662 $(top_builddir)/src/plugins/libtest.la
644 663
645 664
665libextractor_vlc_la_SOURCES = \
666 vlc_extractor.c
667libextractor_vlc_la_LDFLAGS = \
668 $(PLUGINFLAGS)
669libextractor_vlc_la_LIBADD = \
670 -lvlc \
671 $(XLIB)
672
673
646libextractor_wav_la_SOURCES = \ 674libextractor_wav_la_SOURCES = \
647 wav_extractor.c 675 wav_extractor.c
648libextractor_wav_la_LDFLAGS = \ 676libextractor_wav_la_LDFLAGS = \