summaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 8cbe21a..58b0590 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -23,7 +23,9 @@ SUBDIRS = .
EXTRA_DIST = \
fuzz_default.sh \
template_extractor.c \
+ testdata/audiosig.rm \
testdata/archive_test.tar \
+ testdata/chello-elf \
testdata/deb_bzip2.deb \
testdata/dvi_ora.dvi \
testdata/exiv2_iptc.jpg \
@@ -51,6 +53,7 @@ EXTRA_DIST = \
testdata/png_image.png \
testdata/ps_bloomfilter.ps \
testdata/ps_wallace.ps \
+ testdata/ra3.ra \
testdata/riff_flame.avi \
testdata/rpm_test.rpm \
testdata/s3m_2nd_pm.s3m \
@@ -171,6 +174,7 @@ plugin_LTLIBRARIES = \
libextractor_nsf.la \
libextractor_nsfe.la \
libextractor_ps.la \
+ libextractor_real.la \
libextractor_riff.la \
libextractor_s3m.la \
libextractor_sid.la \
@@ -209,6 +213,7 @@ check_PROGRAMS = \
test_odf \
test_ps \
test_png \
+ test_real \
test_riff \
test_s3m \
test_sid \
@@ -562,6 +567,20 @@ test_ps_LDADD = \
$(top_builddir)/src/plugins/libtest.la
+libextractor_real_la_SOURCES = \
+ real_extractor.c
+libextractor_real_la_LDFLAGS = \
+ $(PLUGINFLAGS)
+libextractor_real_la_LIBADD = \
+ -lm \
+ $(XLIB) \
+ $(LE_LIBINTL)
+
+test_real_SOURCES = \
+ test_real.c
+test_real_LDADD = \
+ $(top_builddir)/src/plugins/libtest.la
+
libextractor_riff_la_SOURCES = \
riff_extractor.c
libextractor_riff_la_LDFLAGS = \
@@ -643,6 +662,15 @@ test_tiff_LDADD = \
$(top_builddir)/src/plugins/libtest.la
+libextractor_vlc_la_SOURCES = \
+ vlc_extractor.c
+libextractor_vlc_la_LDFLAGS = \
+ $(PLUGINFLAGS)
+libextractor_vlc_la_LIBADD = \
+ -lvlc \
+ $(XLIB)
+
+
libextractor_wav_la_SOURCES = \
wav_extractor.c
libextractor_wav_la_LDFLAGS = \