aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 8e2af6b..4669a11 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -32,7 +32,8 @@ EXTRA_DIST = template_extractor.c \
32 testdata/ole2_excel.xls \ 32 testdata/ole2_excel.xls \
33 testdata/png_image.png \ 33 testdata/png_image.png \
34 testdata/odf_cg.odt \ 34 testdata/odf_cg.odt \
35 testdata/deb_bzip2.deb 35 testdata/deb_bzip2.deb \
36 testdata/nsf_arkanoid.nsf
36 37
37if HAVE_VORBISFILE 38if HAVE_VORBISFILE
38PLUGIN_OGG=libextractor_ogg.la 39PLUGIN_OGG=libextractor_ogg.la
@@ -117,6 +118,7 @@ check_PROGRAMS = \
117 test_png \ 118 test_png \
118 test_odf \ 119 test_odf \
119 test_zip \ 120 test_zip \
121 test_nsf \
120 $(TEST_ZLIB) \ 122 $(TEST_ZLIB) \
121 $(TEST_OGG) \ 123 $(TEST_OGG) \
122 $(TEST_MIME) \ 124 $(TEST_MIME) \
@@ -164,6 +166,11 @@ libextractor_nsf_la_SOURCES = \
164libextractor_nsf_la_LDFLAGS = \ 166libextractor_nsf_la_LDFLAGS = \
165 $(PLUGINFLAGS) 167 $(PLUGINFLAGS)
166 168
169test_nsf_SOURCES = \
170 test_nsf.c
171test_nsf_LDADD = \
172 $(top_builddir)/src/plugins/libtest.la
173
167 174
168libextractor_nsfe_la_SOURCES = \ 175libextractor_nsfe_la_SOURCES = \
169 nsfe_extractor.c 176 nsfe_extractor.c