aboutsummaryrefslogtreecommitdiff
path: root/src/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/Makefile.am')
-rw-r--r--src/plugins/Makefile.am19
1 files changed, 9 insertions, 10 deletions
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
index 4d4603a..cc44f8b 100644
--- a/src/plugins/Makefile.am
+++ b/src/plugins/Makefile.am
@@ -87,6 +87,7 @@ plugin_LTLIBRARIES = \
87 $(ogg) \ 87 $(ogg) \
88 $(ole2) \ 88 $(ole2) \
89 $(pdf) \ 89 $(pdf) \
90 libextractor_png.la \
90 libextractor_real.la \ 91 libextractor_real.la \
91 $(rpm) \ 92 $(rpm) \
92 libextractor_tar.la \ 93 libextractor_tar.la \
@@ -234,6 +235,14 @@ libextractor_pdf_la_LIBADD = \
234 $(top_builddir)/src/common/libextractor_common.la \ 235 $(top_builddir)/src/common/libextractor_common.la \
235 -lpoppler 236 -lpoppler
236 237
238libextractor_png_la_SOURCES = \
239 png_extractor.c
240libextractor_png_la_LDFLAGS = \
241 $(PLUGINFLAGS)
242libextractor_png_la_LIBADD = \
243 $(top_builddir)/src/common/libextractor_common.la \
244 -lz
245
237libextractor_real_la_SOURCES = \ 246libextractor_real_la_SOURCES = \
238 real_extractor.c 247 real_extractor.c
239libextractor_real_la_LDFLAGS = \ 248libextractor_real_la_LDFLAGS = \
@@ -288,7 +297,6 @@ OLD_LIBS = \
288 $(extrampeg) \ 297 $(extrampeg) \
289 libextractor_nsf.la \ 298 libextractor_nsf.la \
290 libextractor_nsfe.la \ 299 libextractor_nsfe.la \
291 libextractor_png.la \
292 libextractor_ps.la \ 300 libextractor_ps.la \
293 $(extraqt) \ 301 $(extraqt) \
294 libextractor_riff.la \ 302 libextractor_riff.la \
@@ -353,15 +361,6 @@ libextractor_riff_la_LIBADD = \
353 $(LE_LIBINTL) \ 361 $(LE_LIBINTL) \
354 -lm 362 -lm
355 363
356libextractor_png_la_SOURCES = \
357 pngextractor.c
358libextractor_png_la_LDFLAGS = \
359 $(PLUGINFLAGS)
360libextractor_png_la_LIBADD = \
361 $(top_builddir)/src/common/libextractor_common.la \
362 $(top_builddir)/src/main/libextractor.la \
363 -lz
364
365libextractor_sid_la_SOURCES = \ 364libextractor_sid_la_SOURCES = \
366 sidextractor.c 365 sidextractor.c
367libextractor_sid_la_LDFLAGS = \ 366libextractor_sid_la_LDFLAGS = \