aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTheJackiMonster <thejackimonster@gmail.com>2023-02-03 20:49:14 +0100
committerTheJackiMonster <thejackimonster@gmail.com>2023-02-03 20:49:14 +0100
commit71a32ce77a7db1b3bc1230ed908fd9c68ee9dfe8 (patch)
tree038b98be24818f23c9d886ae7e5480fa8364ce75 /configure.ac
parent039a8ce9c56a327d3740134b455b8516bbabb253 (diff)
downloadlibgnunetchat-71a32ce77a7db1b3bc1230ed908fd9c68ee9dfe8.tar.gz
libgnunetchat-71a32ce77a7db1b3bc1230ed908fd9c68ee9dfe8.zip
Use meson as build system
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac251
1 files changed, 0 insertions, 251 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index 9118b56..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,251 +0,0 @@
1# This file is part of GNUnet.
2# Copyright (C) 2022 GNUnet e.V.
3#
4# GNUnet is free software: you can redistribute it and/or modify it
5# under the terms of the GNU Affero General Public License as published
6# by the Free Software Foundation, either version 3 of the License,
7# or (at your option) any later version.
8#
9# GNUnet is distributed in the hope that it will be useful, but
10# WITHOUT ANY WARRANTY; without even the implied warranty of
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
12# Affero General Public License for more details.
13#
14# You should have received a copy of the GNU Affero General Public License
15# along with this program. If not, see <http://www.gnu.org/licenses/>.
16#
17# SPDX-License-Identifier: AGPL3.0-or-later
18#
19# Process this file with autoconf to produce a configure script.
20#
21#
22AC_INIT([libgnunetchat],[m4_esyscmd_s(sh contrib/get_version.sh)],[bug-gnunet@gnu.org])
23
24AC_CONFIG_AUX_DIR([build-aux])
25AC_CONFIG_MACRO_DIRS([m4])
26
27AC_CONFIG_HEADERS([
28 include/gnunet/gnunet_chat_config.h
29])
30
31AC_CANONICAL_TARGET
32AC_CANONICAL_HOST
33
34AM_INIT_AUTOMAKE([tar-ustar])
35AM_SILENT_RULES
36
37# maybe use AC_USE_SYSTEM_EXTENSIONS?
38AH_TOP([#define _GNU_SOURCE 1])
39
40AC_PROG_AWK
41AC_PROG_CC
42AC_PROG_CC_C_O
43AC_PROG_INSTALL
44AC_PROG_LN_S
45AC_PROG_MAKE_SET
46AC_PROG_MKDIR_P
47PKG_PROG_PKG_CONFIG([0.29.2])
48
49LT_INIT([disable-static dlopen])
50
51AS_IF([test "x$enable_shared" = "xno"],
52 [AC_MSG_ERROR([GNUnet works only with shared libraries, sorry])])
53
54# test for GNUnet core
55gnunet=0
56lookin=${prefix}
57GNUNET_CFLAGS=""
58GNUNET_CPPFLAGS=""
59GNUNET_LIBS=""
60AC_MSG_CHECKING(for GNUnet core)
61AC_ARG_WITH(gnunet,
62 [ --with-gnunet=PFX Base of GNUnet installation],
63 [AC_MSG_RESULT([$with_gnunet])
64 AS_CASE([$with_gnunet],
65 [no],[lookin=""],
66 [yes],[lookin="${prefix}"],
67 [lookin="$with_gnunet"])
68 ],
69 [
70 AC_MSG_RESULT([--with-gnunet not specified])
71 PKG_CHECK_MODULES([GNUNET], [gnunetutil >= 0.18.0], gnunet=1)
72 AC_CHECK_HEADERS([gnunet/gnunet_util_lib.h],
73 AC_CHECK_LIB([gnunetutil], [GNUNET_xfree_],
74 [
75 EXT_LIB_PATH="-L${lookin}/lib $EXT_LIB_PATH"
76 if test -d "${lookin}/lib64"; then
77 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH"
78 fi
79 ]
80 ),,[#include <gnunet/platform.h>]
81 )
82 AC_CHECK_HEADERS([gnunet/gnunet_arm_service.h],
83 AC_CHECK_LIB([gnunetarm], [GNUNET_ARM_connect],
84 [
85 gnunet_arm=1
86 ]
87 ),,[#include <gnunet/platform.h>]
88 )
89 AC_CHECK_HEADERS([gnunet/gnunet_fs_service.h],
90 AC_CHECK_LIB([gnunetfs], [GNUNET_FS_start],
91 [
92 gnunet_fs=1
93 ]
94 ),,[#include <gnunet/platform.h>]
95 )
96 AC_CHECK_HEADERS([gnunet/gnunet_gns_service.h],
97 AC_CHECK_LIB([gnunetgns], [GNUNET_GNS_connect],
98 [
99 gnunet_gns=1
100 ]
101 ),,[#include <gnunet/platform.h>]
102 )
103 AC_CHECK_HEADERS([gnunet/gnunet_identity_service.h],
104 AC_CHECK_LIB([gnunetidentity], [GNUNET_IDENTITY_connect],
105 [
106 gnunet_identity=1
107 ]
108 ),,[#include <gnunet/platform.h>]
109 )
110 AC_CHECK_HEADERS([gnunet/gnunet_messenger_service.h],
111 AC_CHECK_LIB([gnunetmessenger], [GNUNET_MESSENGER_connect],
112 [
113 gnunet_messenger=1
114 ]
115 ),,[#include <gnunet/platform.h>]
116 )
117 AC_CHECK_HEADERS([gnunet/gnunet_namestore_service.h],
118 AC_CHECK_LIB([gnunetnamestore], [GNUNET_NAMESTORE_connect],
119 [
120 gnunet_namestore=1
121 ]
122 ),,[#include <gnunet/platform.h>]
123 )
124 AC_CHECK_HEADERS([gnunet/gnunet_regex_service.h],
125 AC_CHECK_LIB([gnunetregex], [GNUNET_REGEX_search],
126 [
127 gnunet_regex=1
128 ]
129 ),,[#include <gnunet/platform.h>]
130 )
131 ]
132)
133
134AS_IF([test "x$gnunet" = "x0" -a ! "x$lookin" = "x"],
135[
136 AC_MSG_CHECKING(for GNUnet util library in $lookin)
137 backup_LIBS="$LIBS"
138 backup_CFLAGS="$CFLAGS"
139 backup_CPPFLAGS="$CPPFLAGS"
140 GNUNET_LIBS="-L${lookin}/lib"
141 if test -d "${lookin}/lib64"; then
142 GNUNET_LIBS="-L${lookin}/lib64 $GNUNET_LIBS"
143 fi
144 GNUNET_CFLAGS="-I${lookin}/include"
145 GNUNET_CPPFLAGS="-I${lookin}/include"
146 LIBS="$GNUNET_LIBS $backup_LIBS"
147 CFLAGS="$GNUNET_CFLAGS $backup_CFLAGS"
148 CPPFLAGS="$GNUNET_CPPFLAGS $backup_CPPFLAGS"
149 AC_CHECK_HEADERS([gnunet/gnunet_util_lib.h],
150 AC_CHECK_LIB([gnunetutil], [GNUNET_xfree_],
151 [
152 gnunet=1
153 EXT_LIB_PATH="-L${lookin}/lib $EXT_LIB_PATH"
154 if test -d "${lookin}/lib64"; then
155 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH"
156 fi
157 ]
158 ),,[#include <gnunet/platform.h>]
159 )
160 AC_CHECK_HEADERS([gnunet/gnunet_arm_service.h],
161 AC_CHECK_LIB([gnunetarm], [GNUNET_ARM_connect],
162 [
163 gnunet_arm=1
164 ]
165 ),,[#include <gnunet/platform.h>]
166 )
167 AC_CHECK_HEADERS([gnunet/gnunet_fs_service.h],
168 AC_CHECK_LIB([gnunetfs], [GNUNET_FS_start],
169 [
170 gnunet_fs=1
171 ]
172 ),,[#include <gnunet/platform.h>]
173 )
174 AC_CHECK_HEADERS([gnunet/gnunet_gns_service.h],
175 AC_CHECK_LIB([gnunetgns], [GNUNET_GNS_connect],
176 [
177 gnunet_gns=1
178 ]
179 ),,[#include <gnunet/platform.h>]
180 )
181 AC_CHECK_HEADERS([gnunet/gnunet_identity_service.h],
182 AC_CHECK_LIB([gnunetidentity], [GNUNET_IDENTITY_connect],
183 [
184 gnunet_identity=1
185 ]
186 ),,[#include <gnunet/platform.h>]
187 )
188 AC_CHECK_HEADERS([gnunet/gnunet_messenger_service.h],
189 AC_CHECK_LIB([gnunetmessenger], [GNUNET_MESSENGER_connect],
190 [
191 gnunet_messenger=1
192 ]
193 ),,[#include <gnunet/platform.h>]
194 )
195 AC_CHECK_HEADERS([gnunet/gnunet_namestore_service.h],
196 AC_CHECK_LIB([gnunetnamestore], [GNUNET_NAMESTORE_connect],
197 [
198 gnunet_namestore=1
199 ]
200 ),,[#include <gnunet/platform.h>]
201 )
202 AC_CHECK_HEADERS([gnunet/gnunet_regex_service.h],
203 AC_CHECK_LIB([gnunetregex], [GNUNET_REGEX_search],
204 [
205 gnunet_regex=1
206 ]
207 ),,[#include <gnunet/platform.h>]
208 )
209
210 LIBS="$backup_LIBS"
211 CFLAGS="$backup_CFLAGS"
212 CPPFLAGS="$backup_CPPFLAGS"
213])
214
215AS_IF([
216 test "x$gnunet" = "x0" ||
217 test "x$gnunet_arm" = "x0" ||
218 test "x$gnunet_fs" = "x0" ||
219 test "x$gnunet_gns" = "x0" ||
220 test "x$gnunet_identity" = "x0" ||
221 test "x$gnunet_messenger" = "x0" ||
222 test "x$gnunet_namestore" = "x0" ||
223 test "x$gnunet_regex" = "x0"
224 ],
225 [
226 AC_MSG_ERROR([libgnunetchat requires GNUnet])
227 ]
228)
229
230AC_SUBST(GNUNET_CFLAGS)
231AC_SUBST(GNUNET_LIBS)
232CFLAGS="$GNUNET_CFLAGS $CFLAGS"
233LIBS="$GNUNET_LIBS $LIBS"
234
235AC_ARG_ENABLE([debug],
236[ --enable-debug turn on debugging],
237[case "${enableval}" in
238 yes) debug=true ;;
239 no) debug=false ;;
240 *) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
241esac],[debug=false])
242AM_CONDITIONAL([DEBUG], [test x$debug = xtrue])
243
244AC_CONFIG_FILES([
245 Makefile
246 include/Makefile
247 src/Makefile
248 tests/Makefile
249])
250
251AC_OUTPUT