aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTheJackiMonster <thejackimonster@gmail.com>2022-09-25 03:58:05 +0200
committerTheJackiMonster <thejackimonster@gmail.com>2022-09-25 03:58:05 +0200
commit839a12cc576e20a8385c157ad53fc427ff0d740e (patch)
treea05635468ace30a5f3dfc004ac4991be6f120634 /configure.ac
parentf109d8a868546f7a7557c5667c7d76f14f262296 (diff)
downloadlibgnunetchat-839a12cc576e20a8385c157ad53fc427ff0d740e.tar.gz
libgnunetchat-839a12cc576e20a8385c157ad53fc427ff0d740e.zip
Convert single makefile to automake
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac61
1 files changed, 61 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..9fb9c7d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,61 @@
1# This file is part of GNUnet.
2# Copyright (C) 2022 GNUnet e.V.
3#
4# GNUnet is free software: you can redistribute it and/or modify it
5# under the terms of the GNU Affero General Public License as published
6# by the Free Software Foundation, either version 3 of the License,
7# or (at your option) any later version.
8#
9# GNUnet is distributed in the hope that it will be useful, but
10# WITHOUT ANY WARRANTY; without even the implied warranty of
11# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
12# Affero General Public License for more details.
13#
14# You should have received a copy of the GNU Affero General Public License
15# along with this program. If not, see <http://www.gnu.org/licenses/>.
16#
17# SPDX-License-Identifier: AGPL3.0-or-later
18#
19# Process this file with autoconf to produce a configure script.
20#
21#
22AC_INIT([libgnunetchat],[m4_esyscmd_s(sh contrib/get_version.sh)],[bug-gnunet@gnu.org])
23
24AC_CONFIG_AUX_DIR([build-aux])
25AC_CONFIG_MACRO_DIRS([m4])
26
27AC_CONFIG_HEADERS([
28 include/gnunet_chat_config.h
29])
30
31AC_CANONICAL_TARGET
32AC_CANONICAL_HOST
33
34AM_INIT_AUTOMAKE([tar-ustar])
35AM_SILENT_RULES([yes])
36
37# maybe use AC_USE_SYSTEM_EXTENSIONS?
38AH_TOP([#define _GNU_SOURCE 1])
39
40AC_PROG_AWK
41AC_PROG_CC
42AC_PROG_CC_C_O
43AC_PROG_INSTALL
44AC_PROG_LN_S
45AC_PROG_MAKE_SET
46AC_PROG_MKDIR_P
47PKG_PROG_PKG_CONFIG([0.29.2])
48
49LT_INIT([disable-static dlopen])
50
51AS_IF([test "x$enable_shared" = "xno"],
52 [AC_MSG_ERROR([GNUnet works only with shared libraries, sorry])])
53
54AC_CONFIG_FILES([
55 Makefile
56 include/Makefile
57 src/Makefile
58 tests/Makefile
59])
60
61AC_OUTPUT