aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTheJackiMonster <thejackimonster@gmail.com>2022-11-13 15:01:46 +0100
committerTheJackiMonster <thejackimonster@gmail.com>2022-11-13 15:01:46 +0100
commitb11b9d9ccb61b03e884199ffb5f4ca9e82c16dd2 (patch)
tree3ff1c3e6ebcc2d9cad56fcddd0378f21014e1bbe /configure.ac
parente98464378ea71c9e2df25de5b11477475df3fed7 (diff)
downloadlibgnunetchat-b11b9d9ccb61b03e884199ffb5f4ca9e82c16dd2.tar.gz
libgnunetchat-b11b9d9ccb61b03e884199ffb5f4ca9e82c16dd2.zip
Improve details of automake configuration
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac78
1 files changed, 65 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index b56e90f..3b8dead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,14 +71,14 @@ AC_ARG_WITH(gnunet,
71 AC_MSG_RESULT([--with-gnunet not specified]) 71 AC_MSG_RESULT([--with-gnunet not specified])
72 PKG_CHECK_MODULES([GNUNET], [gnunetutil >= 0.18.0], gnunet=1) 72 PKG_CHECK_MODULES([GNUNET], [gnunetutil >= 0.18.0], gnunet=1)
73 AC_CHECK_HEADERS([gnunet/gnunet_messenger_service.h], 73 AC_CHECK_HEADERS([gnunet/gnunet_messenger_service.h],
74 AC_CHECK_LIB([gnunetmessenger], [GNUNET_MESSENGER_connect], 74 AC_CHECK_LIB([gnunetmessenger], [GNUNET_MESSENGER_connect],
75 [ 75 [
76 EXT_LIB_PATH="-L${lookin}/lib $EXT_LIB_PATH" 76 EXT_LIB_PATH="-L${lookin}/lib $EXT_LIB_PATH"
77 if test -d "${lookin}/lib64"; then 77 if test -d "${lookin}/lib64"; then
78 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH" 78 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH"
79 fi 79 fi
80 ] 80 ]
81 ),,[#include <gnunet/platform.h>] 81 ),,[#include <gnunet/platform.h>]
82 ) 82 )
83 ] 83 ]
84) 84)
@@ -106,7 +106,34 @@ AS_IF([test "x$gnunet" = "x0" -a ! "x$lookin" = "x"],
106 if test -d "${lookin}/lib64"; then 106 if test -d "${lookin}/lib64"; then
107 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH" 107 EXT_LIB_PATH="-L${lookin}/lib64 $EXT_LIB_PATH"
108 fi 108 fi
109 109 ]
110 ),,[#include <gnunet/platform.h>]
111 )
112 AC_CHECK_HEADERS([gnunet/gnunet_arm_service.h],
113 AC_CHECK_LIB([gnunetarm], [GNUNET_ARM_connect],
114 [
115 gnunet_arm=1
116 ]
117 ),,[#include <gnunet/platform.h>]
118 )
119 AC_CHECK_HEADERS([gnunet/gnunet_fs_service.h],
120 AC_CHECK_LIB([gnunetfs], [GNUNET_FS_start],
121 [
122 gnunet_fs=1
123 ]
124 ),,[#include <gnunet/platform.h>]
125 )
126 AC_CHECK_HEADERS([gnunet/gnunet_gns_service.h],
127 AC_CHECK_LIB([gnunetgns], [GNUNET_GNS_connect],
128 [
129 gnunet_gns=1
130 ]
131 ),,[#include <gnunet/platform.h>]
132 )
133 AC_CHECK_HEADERS([gnunet/gnunet_identity_service.h],
134 AC_CHECK_LIB([gnunetidentity], [GNUNET_IDENTITY_connect],
135 [
136 gnunet_identity=1
110 ] 137 ]
111 ),,[#include <gnunet/platform.h>] 138 ),,[#include <gnunet/platform.h>]
112 ) 139 )
@@ -117,15 +144,40 @@ AS_IF([test "x$gnunet" = "x0" -a ! "x$lookin" = "x"],
117 ] 144 ]
118 ),,[#include <gnunet/platform.h>] 145 ),,[#include <gnunet/platform.h>]
119 ) 146 )
147 AC_CHECK_HEADERS([gnunet/gnunet_namestore_service.h],
148 AC_CHECK_LIB([gnunetnamestore], [GNUNET_NAMESTORE_connect],
149 [
150 gnunet_namestore=1
151 ]
152 ),,[#include <gnunet/platform.h>]
153 )
154 AC_CHECK_HEADERS([gnunet/gnunet_regex_service.h],
155 AC_CHECK_LIB([gnunetregex], [GNUNET_REGEX_search],
156 [
157 gnunet_regex=1
158 ]
159 ),,[#include <gnunet/platform.h>]
160 )
161
120 LIBS="$backup_LIBS" 162 LIBS="$backup_LIBS"
121 CFLAGS="$backup_CFLAGS" 163 CFLAGS="$backup_CFLAGS"
122 CPPFLAGS="$backup_CPPFLAGS" 164 CPPFLAGS="$backup_CPPFLAGS"
123]) 165])
124 166
125AS_IF([test "x$gnunet" = "x0" || test "x$gnunet_messenger" = "x0" ], 167AS_IF([
126 [AC_MSG_ERROR([libgnunetchat requires GNUnet])]) 168 test "x$gnunet" = "x0" ||
127 169 test "x$gnunet_arm" = "x0" ||
128 170 test "x$gnunet_fs" = "x0" ||
171 test "x$gnunet_gns" = "x0" ||
172 test "x$gnunet_identity" = "x0" ||
173 test "x$gnunet_messenger" = "x0" ||
174 test "x$gnunet_namestore" = "x0" ||
175 test "x$gnunet_regex" = "x0"
176 ],
177 [
178 AC_MSG_ERROR([libgnunetchat requires GNUnet])
179 ]
180)
129 181
130AC_SUBST(GNUNET_CFLAGS) 182AC_SUBST(GNUNET_CFLAGS)
131AC_SUBST(GNUNET_LIBS) 183AC_SUBST(GNUNET_LIBS)