aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build59
1 files changed, 59 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..afa51e2
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,59 @@
1#
2# This file is part of GNUnet.
3# Copyright (C) 2023 GNUnet e.V.
4#
5# GNUnet is free software: you can redistribute it and/or modify it
6# under the terms of the GNU Affero General Public License as published
7# by the Free Software Foundation, either version 3 of the License,
8# or (at your option) any later version.
9#
10# GNUnet is distributed in the hope that it will be useful, but
11# WITHOUT ANY WARRANTY; without even the implied warranty of
12# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
13# Affero General Public License for more details.
14#
15# You should have received a copy of the GNU Affero General Public License
16# along with this program. If not, see <http://www.gnu.org/licenses/>.
17#
18# SPDX-License-Identifier: AGPL3.0-or-later
19#
20
21project(
22 'libgnunetchat',
23 'c',
24 license: 'AGPL3.0-or-later',
25 version: run_command('contrib/get_version.sh').stdout().strip(),
26)
27
28src_include = include_directories('src', 'include/gnunet')
29tests_include = include_directories('tests', 'include')
30
31gnunetchat_deps = [
32 dependency('gnunetarm'),
33 dependency('gnunetfs'),
34 dependency('gnunetgns'),
35 dependency('gnunetidentity'),
36 dependency('gnunetmessenger'),
37 dependency('gnunetnamestore'),
38 dependency('gnunetregex'),
39 dependency('gnunetutil'),
40]
41
42subdir('include')
43subdir('src')
44
45gnunetchat_lib = library(
46 'gnunetchat',
47 gnunetchat_sources,
48 install: true,
49 dependencies: gnunetchat_deps,
50 include_directories: src_include,
51 extra_files: gnunetchat_internal,
52)
53
54subdir('tests')
55
56run_target(
57 'docs',
58 command: 'doc/generate.sh',
59)