aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 9c4482c..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CFLAGS = -I$(top_srcdir)/include/gnunet
3
4EXTRA_DIST = \
5 gnunet_chat_contact_intern.c \
6 gnunet_chat_context_intern.c \
7 gnunet_chat_group_intern.c \
8 gnunet_chat_handle_intern.c \
9 gnunet_chat_lib_intern.c \
10 gnunet_chat_lobby_intern.c
11
12lib_LTLIBRARIES = libgnunetchat.la
13
14libgnunetchat_la_SOURCES = \
15 gnunet_chat_account.c gnunet_chat_account.h \
16 gnunet_chat_contact.c gnunet_chat_contact.h \
17 gnunet_chat_context.c gnunet_chat_context.h \
18 gnunet_chat_file.c gnunet_chat_file.h \
19 gnunet_chat_group.c gnunet_chat_group.h \
20 gnunet_chat_handle.c gnunet_chat_handle.h \
21 gnunet_chat_invitation.c gnunet_chat_invitation.h \
22 gnunet_chat_lobby.c gnunet_chat_lobby.h \
23 gnunet_chat_message.c gnunet_chat_message.h \
24 gnunet_chat_uri.c gnunet_chat_uri.h \
25 gnunet_chat_util.c gnunet_chat_util.h \
26 gnunet_chat_lib.c
27
28libgnunetchat_la_LIBADD = \
29 -lgnunetarm \
30 -lgnunetfs \
31 -lgnunetgns \
32 -lgnunetidentity \
33 -lgnunetmessenger \
34 -lgnunetnamestore \
35 -lgnunetregex \
36 -lgnunetutil
37
38libgnunetchat_la_CFLAGS = \
39 -fPIC -pedantic -Wall -Wextra
40
41if DEBUG
42libgnunetchat_la_CFLAGS += \
43 -O0 -D _DEBUG -ggdb3
44else
45libgnunetchat_la_CFLAGS += \
46 -O2 -D NDEBUG
47endif