aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-09-05 12:04:54 +0000
committerChristian Grothoff <christian@grothoff.org>2016-09-05 12:04:54 +0000
commit5ef83163f7535b36c9ac5b3c302284a2ccaacb30 (patch)
treef32973763f3d298474f8b387725b26f9f68603f5 /Makefile.am
parentab185489bc22430ddce5a9c7112074361f0a92cb (diff)
downloadlibmicrohttpd-5ef83163f7535b36c9ac5b3c302284a2ccaacb30.tar.gz
libmicrohttpd-5ef83163f7535b36c9ac5b3c302284a2ccaacb30.zip
adding gettext stuff for fixing #4614
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 192dfd2e..1a47fba2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
1# This Makefile.am is in the public domain 1# This Makefile.am is in the public domain
2ACLOCAL_AMFLAGS = -I m4 2ACLOCAL_AMFLAGS = -I m4
3SUBDIRS = contrib src m4 . 3SUBDIRS = contrib m4 src po .
4W32COMMON = w32/common/gen_dll_res.ps1 w32/common/microhttpd_dll_res_vc.rc.in w32/common/microhttpd_dll_res_vc.rc \ 4W32COMMON = w32/common/gen_dll_res.ps1 w32/common/microhttpd_dll_res_vc.rc.in w32/common/microhttpd_dll_res_vc.rc \
5 w32/common/MHD_config.h w32/common/vs_dirs.props w32/common/common-build-settings.vcxproj \ 5 w32/common/MHD_config.h w32/common/vs_dirs.props w32/common/common-build-settings.vcxproj \
6 w32/common/libmicrohttpd-build-settings.vcxproj w32/common/libmicrohttpd-files.vcxproj w32/common/libmicrohttpd-filters.vcxproj \ 6 w32/common/libmicrohttpd-build-settings.vcxproj w32/common/libmicrohttpd-files.vcxproj w32/common/libmicrohttpd-filters.vcxproj \
@@ -9,16 +9,19 @@ W32COMMON = w32/common/gen_dll_res.ps1 w32/common/microhttpd_dll_res_vc.rc.in w3
9W32VS2013 = w32/VS2013/libmicrohttpd.vcxproj w32/VS2013/libmicrohttpd.vcxproj.filters \ 9W32VS2013 = w32/VS2013/libmicrohttpd.vcxproj w32/VS2013/libmicrohttpd.vcxproj.filters \
10 w32/VS2013/hellobrowser.vcxproj w32/VS2013/hellobrowser.vcxproj.filters \ 10 w32/VS2013/hellobrowser.vcxproj w32/VS2013/hellobrowser.vcxproj.filters \
11 w32/VS2013/simplepost.vcxproj w32/VS2013/largepost.vcxproj \ 11 w32/VS2013/simplepost.vcxproj w32/VS2013/largepost.vcxproj \
12 w32/VS2013/libmicrohttpd.sln 12 w32/VS2013/libmicrohttpd.sln
13W32VS2015 = w32/VS2015/libmicrohttpd.vcxproj w32/VS2015/libmicrohttpd.vcxproj.filters \ 13W32VS2015 = w32/VS2015/libmicrohttpd.vcxproj w32/VS2015/libmicrohttpd.vcxproj.filters \
14 w32/VS2015/hellobrowser.vcxproj w32/VS2015/hellobrowser.vcxproj.filters \ 14 w32/VS2015/hellobrowser.vcxproj w32/VS2015/hellobrowser.vcxproj.filters \
15 w32/VS2015/simplepost.vcxproj w32/VS2015/largepost.vcxproj \ 15 w32/VS2015/simplepost.vcxproj w32/VS2015/largepost.vcxproj \
16 w32/VS2015/libmicrohttpd.sln 16 w32/VS2015/libmicrohttpd.sln
17EXTRA_DIST = acinclude.m4 libmicrohttpd.pc.in \ 17EXTRA_DIST = \
18 ABOUT-NLS \
19 acinclude.m4 \
20 libmicrohttpd.pc.in \
18 $(W32COMMON) $(W32VS2013) $(W32VS2015) 21 $(W32COMMON) $(W32VS2013) $(W32VS2015)
19 22
20pkgconfigdir = $(libdir)/pkgconfig 23pkgconfigdir = $(libdir)/pkgconfig
21pkgconfig_DATA = libmicrohttpd.pc 24pkgconfig_DATA = libmicrohttpd.pc
22 25
23if BUILD_DOC 26if BUILD_DOC
24SUBDIRS += doc 27SUBDIRS += doc