aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2017-11-06 18:32:41 +0300
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2017-11-06 18:32:41 +0300
commit042ca763558b9ce724e9850f9a89fa5aefe943ab (patch)
tree72834bc35200b5bee070880124c509dd15e67b3d /configure.ac
parent19d12c4ef73ae4fcd9095cb9ad544a4186d971c0 (diff)
downloadlibmicrohttpd-042ca763558b9ce724e9850f9a89fa5aefe943ab.tar.gz
libmicrohttpd-042ca763558b9ce724e9850f9a89fa5aefe943ab.zip
configure.ac: do not ignore user-defined GNUTLS_{CPP,LD}FLAGS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 842b8604..abf436c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1345,8 +1345,6 @@ AC_CHECK_PROG([have_socat],[socat], [yes], [no])
1345AM_CONDITIONAL([HAVE_ZZUF], [test "x$have_zzuf" = "xyes"]) 1345AM_CONDITIONAL([HAVE_ZZUF], [test "x$have_zzuf" = "xyes"])
1346AM_CONDITIONAL([HAVE_SOCAT], [test "x$have_socat" = "xyes"]) 1346AM_CONDITIONAL([HAVE_SOCAT], [test "x$have_socat" = "xyes"])
1347 1347
1348GNUTLS_CPPFLAGS=""
1349GNUTLS_LDFLAGS=""
1350have_gnutls=no 1348have_gnutls=no
1351have_gnutls_sni=no 1349have_gnutls_sni=no
1352have_gcrypt=no 1350have_gcrypt=no
@@ -1371,6 +1369,8 @@ AC_ARG_WITH([[gnutls]],
1371 case $with_gnutls in 1369 case $with_gnutls in
1372 no) 1370 no)
1373 AC_MSG_RESULT([[GnuTLS disabled]]) 1371 AC_MSG_RESULT([[GnuTLS disabled]])
1372 AS_UNSET([GNUTLS_CPPFLAGS])
1373 AS_UNSET([GNUTLS_LDFLAGS])
1374 ;; 1374 ;;
1375 yes) 1375 yes)
1376 AC_MSG_RESULT([[automatically, forced]]) 1376 AC_MSG_RESULT([[automatically, forced]])
@@ -1449,6 +1449,8 @@ AS_IF([test "x$with_gnutls" != "xno" && test "x$have_gnutls" != "xyes"],
1449 CFLAGS="$SAVE_CFLAGS" 1449 CFLAGS="$SAVE_CFLAGS"
1450 LDFLAGS="$SAVE_LDFLAGS" 1450 LDFLAGS="$SAVE_LDFLAGS"
1451 LIBS="$SAVE_LIBS" 1451 LIBS="$SAVE_LIBS"
1452 AS_UNSET([GNUTLS_CPPFLAGS])
1453 AS_UNSET([GNUTLS_LDFLAGS])
1452 ], 1454 ],
1453 [ 1455 [
1454 # check for GnuTLS at default paths 1456 # check for GnuTLS at default paths
@@ -1538,6 +1540,10 @@ choke me now
1538 CFLAGS="$SAVE_CFLAGS" 1540 CFLAGS="$SAVE_CFLAGS"
1539 LDFLAGS="$SAVE_LDFLAGS" 1541 LDFLAGS="$SAVE_LDFLAGS"
1540 LIBS="$SAVE_LIBS" 1542 LIBS="$SAVE_LIBS"
1543 ],
1544 [
1545 AS_UNSET([GNUTLS_CPPFLAGS])
1546 AS_UNSET([GNUTLS_LDFLAGS])
1541 ] 1547 ]
1542 ) 1548 )
1543 1549