aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-05-13 09:34:02 +0200
committerChristian Grothoff <christian@grothoff.org>2019-05-13 09:34:02 +0200
commit09e1f5686128c5e8fa57396ffefb987fc70bb45f (patch)
tree5b74dd838ca25969f985c51248fcc8347821b7ec /configure.ac
parent6ef94cf448e11a51c4b24d7347351047c39e3afe (diff)
downloadlibmicrohttpd-09e1f5686128c5e8fa57396ffefb987fc70bb45f.tar.gz
libmicrohttpd-09e1f5686128c5e8fa57396ffefb987fc70bb45f.zip
use AS_CASE/AS_IF
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 21 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 9113301e..bb95d165 100644
--- a/configure.ac
+++ b/configure.ac
@@ -317,11 +317,11 @@ AS_CASE(["$host_os"],
317 LIBS="$LIBS -lws2_32" 317 LIBS="$LIBS -lws2_32"
318 AC_CHECK_HEADERS([winsock2.h ws2tcpip.h], [], [AC_MSG_ERROR([[Winsock2 headers are required for W32]])], [AC_INCLUDES_DEFAULT]) 318 AC_CHECK_HEADERS([winsock2.h ws2tcpip.h], [], [AC_MSG_ERROR([[Winsock2 headers are required for W32]])], [AC_INCLUDES_DEFAULT])
319 AC_CACHE_CHECK([for MS lib utility], [ac_cv_use_ms_lib_tool], 319 AC_CACHE_CHECK([for MS lib utility], [ac_cv_use_ms_lib_tool],
320 [[mslibcheck=`lib 2>&1` 320 [mslibcheck=`lib 2>&1`
321 AS_IF([$mslibcheck = "Microsoft (R) Library Manager"*], 321 AS_IF([test $mslibcheck = "Microsoft (R) Library Manager"*],
322 [ac_cv_use_ms_lib_tool=yes], 322 [ac_cv_use_ms_lib_tool=yes],
323 [ac_cv_use_ms_lib_tool=no]) 323 [ac_cv_use_ms_lib_tool=no])
324 ]]) 324 ])
325 AS_IF([test "x$ac_cv_use_ms_lib_tool" = "xyes"], 325 AS_IF([test "x$ac_cv_use_ms_lib_tool" = "xyes"],
326 [AC_SUBST([MS_LIB_TOOL], [[lib]])]) 326 [AC_SUBST([MS_LIB_TOOL], [[lib]])])
327 AC_SUBST([lt_cv_objdir]) 327 AC_SUBST([lt_cv_objdir])
@@ -1495,18 +1495,18 @@ AC_MSG_CHECKING([[how to find GnuTLS library]])
1495AC_ARG_WITH([[gnutls]], 1495AC_ARG_WITH([[gnutls]],
1496 [AS_HELP_STRING([[--with-gnutls[=PFX]]],[use GnuTLS for HTTPS support, optional PFX overrides pkg-config data for GnuTLS headers (PFX/include) and libs (PFX/lib)])], 1496 [AS_HELP_STRING([[--with-gnutls[=PFX]]],[use GnuTLS for HTTPS support, optional PFX overrides pkg-config data for GnuTLS headers (PFX/include) and libs (PFX/lib)])],
1497 [ 1497 [
1498 case $with_gnutls in 1498 AS_CASE([$with_gnutls],
1499 no) 1499 [no],[
1500 AC_MSG_RESULT([[GnuTLS disabled]]) 1500 AC_MSG_RESULT([[GnuTLS disabled]])
1501 AS_UNSET([GNUTLS_CPPFLAGS]) 1501 AS_UNSET([GNUTLS_CPPFLAGS])
1502 AS_UNSET([GNUTLS_CFLAGS]) 1502 AS_UNSET([GNUTLS_CFLAGS])
1503 AS_UNSET([GNUTLS_LDFLAGS]) 1503 AS_UNSET([GNUTLS_LDFLAGS])
1504 AS_UNSET([GNUTLS_LIBS]) 1504 AS_UNSET([GNUTLS_LIBS])
1505 ;; 1505 ],
1506 yes) 1506 [yes],[
1507 AC_MSG_RESULT([[automatically, forced]]) 1507 AC_MSG_RESULT([[automatically, forced]])
1508 ;; 1508 ],
1509 *) 1509 [
1510 AC_MSG_RESULT([[-I$with_gnutls/include -L$with_gnutls/lib -lgnutls]]) 1510 AC_MSG_RESULT([[-I$with_gnutls/include -L$with_gnutls/lib -lgnutls]])
1511 SAVE_LDFLAGS="$LDFLAGS" 1511 SAVE_LDFLAGS="$LDFLAGS"
1512 SAVE_CPPFLAGS="$CPPFLAGS" 1512 SAVE_CPPFLAGS="$CPPFLAGS"
@@ -1528,8 +1528,7 @@ AC_ARG_WITH([[gnutls]],
1528 CFLAGS="$SAVE_CFLAGS" 1528 CFLAGS="$SAVE_CFLAGS"
1529 LDFLAGS="$SAVE_LDFLAGS" 1529 LDFLAGS="$SAVE_LDFLAGS"
1530 LIBS="$SAVE_LIBS" 1530 LIBS="$SAVE_LIBS"
1531 ;; 1531 ])
1532 esac
1533 ], 1532 ],
1534 [AC_MSG_RESULT([[automatically]]) 1533 [AC_MSG_RESULT([[automatically]])
1535 ]) 1534 ])
@@ -2063,11 +2062,9 @@ src/testzzuf/Makefile])
2063AC_OUTPUT 2062AC_OUTPUT
2064 2063
2065# Finally: summary 2064# Finally: summary
2066if test "x$enable_curl" != "xyes"; then 2065AS_IF([test "x$enable_curl" != "xyes"],
2067 MSG_CURL="no, many unit tests will not run" 2066 [MSG_CURL="no, many unit tests will not run"],
2068else 2067 [MSG_CURL="yes"])
2069 MSG_CURL="yes"
2070fi
2071 2068
2072AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary: 2069AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary:
2073 Target directory: ${prefix} 2070 Target directory: ${prefix}
@@ -2093,21 +2090,16 @@ AC_MSG_NOTICE([GNU libmicrohttpd ${PACKAGE_VERSION} Configuration Summary:
2093 Test with libcurl: ${MSG_CURL} 2090 Test with libcurl: ${MSG_CURL}
2094]) 2091])
2095 2092
2096if test "x$enable_https" = "xyes" 2093AS_IF([test "x$enable_https" = "xyes"],
2097then 2094 [AC_MSG_NOTICE([HTTPS subsystem configuration:
2098 AC_MSG_NOTICE([HTTPS subsystem configuration:
2099 License : LGPL only 2095 License : LGPL only
2100 ]) 2096 ])],
2101else 2097 [AC_MSG_NOTICE([
2102 AC_MSG_NOTICE([
2103 License : LGPL or eCos 2098 License : LGPL or eCos
2104]) 2099 ])])
2105fi
2106 2100
2107if test "x$enable_bauth" != "xyes" || \ 2101AS_IF([test "x$enable_bauth" != "xyes" || \
2108 test "x$enable_dauth" != "xyes" || \ 2102 test "x$enable_dauth" != "xyes" || \
2109 test "x$enable_httpupgrade" != "xyes" || \ 2103 test "x$enable_httpupgrade" != "xyes" || \
2110 test "x$enable_postprocessor" != "xyes" 2104 test "x$enable_postprocessor" != "xyes"],
2111then 2105 [AC_MSG_NOTICE([WARNING: This will be a custom build with missing symbols. Do NOT use this build in a distribution. Building with these kinds of configure options is only for custom builds for embedded systems.])])
2112 AC_MSG_NOTICE([WARNING: This will be a custom build with missing symbols. Do NOT use this build in a distribution. Building with these kinds of configure options is only for custom builds for embedded systems.])
2113fi