aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-09-11 15:11:53 +0200
committerChristian Grothoff <christian@grothoff.org>2018-09-11 15:11:53 +0200
commit7ade892317e91c34de82e103e129b9cb4e54f5cf (patch)
treea1285285894cddba4e47398d82f8a3f806382905 /configure.ac
parent9624d2f58ee09fd6bd109bb89b6695f8447f17a4 (diff)
downloadlibmicrohttpd-7ade892317e91c34de82e103e129b9cb4e54f5cf.tar.gz
libmicrohttpd-7ade892317e91c34de82e103e129b9cb4e54f5cf.zip
clean up use of GNUTLS linker options in various places, re-add SAVE_LIBS restoration to configure.ac to avoid linking indiscriminately against GnuTLS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 356f7fef..e2f9891d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1502,6 +1502,8 @@ AC_ARG_WITH([[gnutls]],
1502 AC_MSG_RESULT([[-I$with_gnutls/include -L$with_gnutls/lib -lgnutls]]) 1502 AC_MSG_RESULT([[-I$with_gnutls/include -L$with_gnutls/lib -lgnutls]])
1503 SAVE_LDFLAGS="$LDFLAGS" 1503 SAVE_LDFLAGS="$LDFLAGS"
1504 SAVE_CPPFLAGS="$CPPFLAGS" 1504 SAVE_CPPFLAGS="$CPPFLAGS"
1505 SAVE_CFLAGS="$CFLAGS"
1506 SAVE_LIBS="$LIBS"
1505 LDFLAGS="-L$with_gnutls/lib $LDFLAGS" 1507 LDFLAGS="-L$with_gnutls/lib $LDFLAGS"
1506 CPPFLAGS="-I$with_gnutls/include $CPPFLAGS" 1508 CPPFLAGS="-I$with_gnutls/include $CPPFLAGS"
1507 have_gnutls_pkgcfg=no 1509 have_gnutls_pkgcfg=no
@@ -1514,6 +1516,10 @@ AC_ARG_WITH([[gnutls]],
1514 have_gnutls=yes 1516 have_gnutls=yes
1515 ])], [], [AC_INCLUDES_DEFAULT]) 1517 ])], [], [AC_INCLUDES_DEFAULT])
1516 AS_IF([test "x$have_gnutls" != "xyes"], [AC_MSG_ERROR([can't find usable libgnutls at specified prefix $with_gnutls])]) 1518 AS_IF([test "x$have_gnutls" != "xyes"], [AC_MSG_ERROR([can't find usable libgnutls at specified prefix $with_gnutls])])
1519 CPPFLAGS="$SAVE_CPPFLAGS"
1520 CFLAGS="$SAVE_CFLAGS"
1521 LDFLAGS="$SAVE_LDFLAGS"
1522 LIBS="$SAVE_LIBS"
1517 ;; 1523 ;;
1518 esac 1524 esac
1519 ], 1525 ],
@@ -1659,7 +1665,8 @@ AS_IF([test "x$with_gnutls" != "xno" && test "x$have_gnutls" != "xyes"],
1659 ) 1665 )
1660 ] 1666 ]
1661) 1667)
1662AS_IF([test "x$have_gnutls" != "xyes" && test "x$with_gnutls" = "xyes"], [AC_MSG_ERROR([[can't find usable libgnutls]])]) 1668AS_IF([test "x$have_gnutls" != "xyes" && test "x$with_gnutls" = "xyes"],
1669 [AC_MSG_ERROR([[can't find usable libgnutls]])])
1663# 1670#
1664# End of large unindented block 1671# End of large unindented block
1665# 1672#