aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-10-22 11:48:54 +0200
committerChristian Grothoff <christian@grothoff.org>2020-10-22 11:48:54 +0200
commitc43779a4bed4d372153e12ba94b9c4c6520050ef (patch)
tree858e3c63a8ad0800454dede937f601b42b4f9ac8 /configure.ac
parent4b18c05142f821fb6b1ba7e8841fce9b623ad9e3 (diff)
downloadlibmicrohttpd-c43779a4bed4d372153e12ba94b9c4c6520050ef.tar.gz
libmicrohttpd-c43779a4bed4d372153e12ba94b9c4c6520050ef.zip
fix typos
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 3d1b679c..a3596813 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,7 +378,7 @@ AM_CONDITIONAL([CYGWIN_TARGET], [[test "x$os_is_windows" = "xyes" && \
378 378
379AS_VAR_IF([os_is_windows], ["yes"], 379AS_VAR_IF([os_is_windows], ["yes"],
380 [ 380 [
381 AC_MSG_CHECKING([[wheather target W32 version is specified by precomiler defines]]) 381 AC_MSG_CHECKING([[whether target W32 version is specified by precomiler defines]])
382 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ 382 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
383/* Note: check logic is reversed for easy log reading */ 383/* Note: check logic is reversed for easy log reading */
384#ifdef WINVER 384#ifdef WINVER
@@ -435,11 +435,11 @@ choke me now;
435#include <windows.h> 435#include <windows.h>
436#endif 436#endif
437 437
438#if _WIN32_WINNT+0 == 0x0501 438#if _WIN32_WINNT+0 == 0x0501
439#error _WIN32_WINNT is 0x0501 439#error _WIN32_WINNT is 0x0501
440choke me now; 440choke me now;
441#endif 441#endif
442#if _WIN32_WINNT+0 == 0x0502 442#if _WIN32_WINNT+0 == 0x0502
443#error _WIN32_WINNT is 0x0502 443#error _WIN32_WINNT is 0x0502
444choke me now; 444choke me now;
445#endif 445#endif
@@ -459,7 +459,7 @@ choke me now;
459#include <windows.h> 459#include <windows.h>
460#endif 460#endif
461 461
462#if _WIN32_WINNT+0 < 0x0600 462#if _WIN32_WINNT+0 < 0x0600
463#error _WIN32_WINNT is less than 0x0600 but greater than 0x0502 463#error _WIN32_WINNT is less than 0x0600 but greater than 0x0502
464choke me now; 464choke me now;
465#endif 465#endif
@@ -477,7 +477,7 @@ choke me now;
477#include <windows.h> 477#include <windows.h>
478#endif 478#endif
479 479
480#if _WIN32_WINNT+0 == 0x0600 480#if _WIN32_WINNT+0 == 0x0600
481#error _WIN32_WINNT is 0x0600 481#error _WIN32_WINNT is 0x0600
482choke me now; 482choke me now;
483#endif 483#endif
@@ -489,7 +489,7 @@ choke me now;
489 ) 489 )
490 ] 490 ]
491 ) 491 )
492 492
493 AS_VAR_SET_IF([mhd_w32_ver], [], 493 AS_VAR_SET_IF([mhd_w32_ver], [],
494 [ 494 [
495 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ 495 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
@@ -500,7 +500,7 @@ choke me now;
500#include <windows.h> 500#include <windows.h>
501#endif 501#endif
502 502
503#if _WIN32_WINNT+0 > 0x0600 503#if _WIN32_WINNT+0 > 0x0600
504#error _WIN32_WINNT is greater than 0x0600 504#error _WIN32_WINNT is greater than 0x0600
505choke me now; 505choke me now;
506#endif 506#endif
@@ -520,7 +520,7 @@ choke me now;
520 mhd_w32_ver="Vista" 520 mhd_w32_ver="Vista"
521 mhd_w32_ver_msg="Vista (default, override by CPPFLAGS=-D_WIN32_WINNT=0xNNNN)" 521 mhd_w32_ver_msg="Vista (default, override by CPPFLAGS=-D_WIN32_WINNT=0xNNNN)"
522 CPPFLAGS="$CPPFLAGS -D_WIN32_WINNT=0x0600" 522 CPPFLAGS="$CPPFLAGS -D_WIN32_WINNT=0x0600"
523 AC_MSG_CHECKING([[wheather headers accept _WIN32_WINNT=0x0600]]) 523 AC_MSG_CHECKING([[whether headers accept _WIN32_WINNT=0x0600]])
524 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ 524 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
525#ifdef HAVE_SDKDDKVER_H 525#ifdef HAVE_SDKDDKVER_H
526#include <sdkddkver.h> 526#include <sdkddkver.h>