aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2016-02-05 20:47:58 +0000
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2016-02-05 20:47:58 +0000
commit96010724e3862241ff01a1b62f88499d2adc7827 (patch)
tree70786848535aacc7ec8f40113c923634f09da486 /src/microhttpd/Makefile.am
parentbc162a8e859d360d77f57df8fdf5a8daf746e72d (diff)
downloadlibmicrohttpd-96010724e3862241ff01a1b62f88499d2adc7827.tar.gz
libmicrohttpd-96010724e3862241ff01a1b62f88499d2adc7827.zip
Added test for checking ability of shutdown() on socket to trigger poll()
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 58284d17..67ec3cd8 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -141,6 +141,7 @@ endif
141 141
142check_PROGRAMS = \ 142check_PROGRAMS = \
143 test_shutdown_select \ 143 test_shutdown_select \
144 test_shutdown_poll \
144 test_daemon 145 test_daemon
145 146
146if HAVE_POSTPROCESSOR 147if HAVE_POSTPROCESSOR
@@ -154,7 +155,8 @@ TESTS = $(check_PROGRAMS)
154 155
155if !HAVE_LISTEN_SHUTDOWN 156if !HAVE_LISTEN_SHUTDOWN
156XFAIL_TESTS = \ 157XFAIL_TESTS = \
157 test_shutdown_select 158 test_shutdown_select \
159 test_shutdown_poll
158endif 160endif
159 161
160test_daemon_SOURCES = \ 162test_daemon_SOURCES = \
@@ -193,3 +195,12 @@ test_shutdown_select_CFLAGS = \
193test_shutdown_select_LDADD = \ 195test_shutdown_select_LDADD = \
194 $(PTHREAD_LIBS) 196 $(PTHREAD_LIBS)
195endif 197endif
198
199test_shutdown_poll_SOURCES = \
200 test_shutdown_select.c
201if USE_POSIX_THREADS
202test_shutdown_poll_CFLAGS = \
203 test_shutdown_select_CFLAGS
204test_shutdown_poll_LDADD = \
205 test_shutdown_select_LDADD
206endif