aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2016-11-05 13:43:44 +0300
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2016-11-07 14:39:09 +0300
commit9ea89671719e23e5bcff40b17a3c0fe66c047cc3 (patch)
tree7d4b77138644aeb68b39fd1afb5c511cc1a833ef /src/microhttpd/Makefile.am
parent8b10b7801c17f9d589cdb4b5131e5621ee088827 (diff)
downloadlibmicrohttpd-9ea89671719e23e5bcff40b17a3c0fe66c047cc3.tar.gz
libmicrohttpd-9ea89671719e23e5bcff40b17a3c0fe66c047cc3.zip
Combine upgrade tests into single source file, port to platforms without fork()
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am30
1 files changed, 23 insertions, 7 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 81dc95c2..cc48d11d 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -152,10 +152,12 @@ check_PROGRAMS = \
152 test_shutdown_poll \ 152 test_shutdown_poll \
153 test_daemon 153 test_daemon
154 154
155if HAVE_POSIX_THREADS
155if ENABLE_UPGRADE 156if ENABLE_UPGRADE
156 check_PROGRAMS += test_upgrade 157 check_PROGRAMS += test_upgrade
157if ENABLE_HTTPS 158if ENABLE_HTTPS
158 check_PROGRAMS += test_upgrade_ssl 159 check_PROGRAMS += test_upgrade_tls
160endif
159endif 161endif
160endif 162endif
161 163
@@ -180,14 +182,28 @@ test_daemon_LDADD = \
180 $(top_builddir)/src/microhttpd/libmicrohttpd.la 182 $(top_builddir)/src/microhttpd/libmicrohttpd.la
181 183
182test_upgrade_SOURCES = \ 184test_upgrade_SOURCES = \
183 test_upgrade.c 185 test_upgrade.c test_helpers.h mhd_sockets.h
186test_upgrade_CPPFLAGS = \
187 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS)
188test_upgrade_CFLAGS = \
189 $(AM_CFLAGS) $(PTHREAD_CFLAGS)
190test_upgrade_LDFLAGS = \
191 $(GNUTLS_LDFLAGS)
184test_upgrade_LDADD = \ 192test_upgrade_LDADD = \
185 $(top_builddir)/src/microhttpd/libmicrohttpd.la 193 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
194 $(PTHREAD_LIBS)
186 195
187test_upgrade_ssl_SOURCES = \ 196test_upgrade_tls_SOURCES = \
188 test_upgrade_ssl.c 197 test_upgrade.c test_helpers.h mhd_sockets.h
189test_upgrade_ssl_LDADD = \ 198test_upgrade_tls_CPPFLAGS = \
190 $(top_builddir)/src/microhttpd/libmicrohttpd.la 199 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS)
200test_upgrade_tls_CFLAGS = \
201 $(AM_CFLAGS) $(PTHREAD_CFLAGS)
202test_upgrade_tls_LDFLAGS = \
203 $(GNUTLS_LDFLAGS)
204test_upgrade_tls_LDADD = \
205 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
206 $(PTHREAD_LIBS)
191 207
192test_postprocessor_SOURCES = \ 208test_postprocessor_SOURCES = \
193 test_postprocessor.c 209 test_postprocessor.c