aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2017-05-08 17:24:19 +0300
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2017-05-09 22:20:42 +0300
commite93439da71e027cafe5b2788a997cbfc85d193c8 (patch)
treea4004d13b98d12b1529eec696c9ef1d2401331c5 /src/microhttpd/Makefile.am
parentb03ee4c52a6deebdcad3f12a18c4bd4f947f167b (diff)
downloadlibmicrohttpd-e93439da71e027cafe5b2788a997cbfc85d193c8.tar.gz
libmicrohttpd-e93439da71e027cafe5b2788a997cbfc85d193c8.zip
Added function for detection of token inside comma-separated string, added tests
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 3f1b828f..36121539 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -142,6 +142,7 @@ endif
142check_PROGRAMS = \ 142check_PROGRAMS = \
143 test_str_compare \ 143 test_str_compare \
144 test_str_to_value \ 144 test_str_to_value \
145 test_str_token \
145 test_http_reasons \ 146 test_http_reasons \
146 test_shutdown_select \ 147 test_shutdown_select \
147 test_shutdown_poll \ 148 test_shutdown_poll \
@@ -251,6 +252,9 @@ test_str_compare_SOURCES = \
251test_str_to_value_SOURCES = \ 252test_str_to_value_SOURCES = \
252 test_str.c test_helpers.h mhd_str.c 253 test_str.c test_helpers.h mhd_str.c
253 254
255test_str_token_SOURCES = \
256 test_str_token.c mhd_str.c
257
254test_http_reasons_SOURCES = \ 258test_http_reasons_SOURCES = \
255 test_http_reasons.c \ 259 test_http_reasons.c \
256 reason_phrase.c mhd_str.c mhd_str.h 260 reason_phrase.c mhd_str.c mhd_str.h