aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 07897639..0321ff9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,7 +223,7 @@ AC_CHECK_HEADERS([sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h netinet/
223 223
224AC_CHECK_HEADERS([search.h], AM_CONDITIONAL(HAVE_TSEARCH, true), AM_CONDITIONAL(HAVE_TSEARCH, false)) 224AC_CHECK_HEADERS([search.h], AM_CONDITIONAL(HAVE_TSEARCH, true), AM_CONDITIONAL(HAVE_TSEARCH, false))
225 225
226# Check for pipe/socketpair signaling 226# Check for pipe/socketpair signaling
227AC_MSG_CHECKING([[whether to disable pipes signaling]]) 227AC_MSG_CHECKING([[whether to disable pipes signaling]])
228AC_ARG_ENABLE([[pipes]], 228AC_ARG_ENABLE([[pipes]],
229 [AS_HELP_STRING([[--disable-pipes]], [[disable internal singalling by pipes and use socket pair instead]])], 229 [AS_HELP_STRING([[--disable-pipes]], [[disable internal singalling by pipes and use socket pair instead]])],
@@ -231,7 +231,7 @@ AC_ARG_ENABLE([[pipes]],
231AS_IF([[test "x$os_is_windows" = "xyes"]], [disable_pipes=yes 231AS_IF([[test "x$os_is_windows" = "xyes"]], [disable_pipes=yes
232 AC_MSG_RESULT([[yes, forced on W32]])], 232 AC_MSG_RESULT([[yes, forced on W32]])],
233 [[test "x$enable_pipes" != "xno"]], [disable_pipes=no 233 [[test "x$enable_pipes" != "xno"]], [disable_pipes=no
234 AC_MSG_RESULT([[$disable_pipes]])], 234 AC_MSG_RESULT([[$disable_pipes]])],
235 [AC_LINK_IFELSE([AC_LANG_PROGRAM([[ 235 [AC_LINK_IFELSE([AC_LANG_PROGRAM([[
236 #ifdef HAVE_SYS_TYPES_H 236 #ifdef HAVE_SYS_TYPES_H
237 #include <sys/types.h> 237 #include <sys/types.h>
@@ -242,8 +242,8 @@ AS_IF([[test "x$os_is_windows" = "xyes"]], [disable_pipes=yes
242 ]],[[ 242 ]],[[
243 int sv[2]; 243 int sv[2];
244 if (socketpair(AF_UNIX, SOCK_STREAM, 0, sv) != 0) return 1 244 if (socketpair(AF_UNIX, SOCK_STREAM, 0, sv) != 0) return 1
245 245
246 ]])], 246 ]])],
247 [disable_pipes=yes 247 [disable_pipes=yes
248 AC_MSG_RESULT([[yes, socketpair in available]])], 248 AC_MSG_RESULT([[yes, socketpair in available]])],
249 [disable_pipes=no 249 [disable_pipes=no
@@ -623,6 +623,7 @@ doc/examples/Makefile
623m4/Makefile 623m4/Makefile
624src/Makefile 624src/Makefile
625src/include/Makefile 625src/include/Makefile
626src/platform/Makefile
626src/microhttpd/Makefile 627src/microhttpd/Makefile
627src/microspdy/Makefile 628src/microspdy/Makefile
628src/spdy2http/Makefile 629src/spdy2http/Makefile