aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index cbe548f7..173a5bf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,11 @@ AC_SUBST([PACKAGE_VERSION_MINOR])
81AC_SUBST([PACKAGE_VERSION_SUBMINOR]) 81AC_SUBST([PACKAGE_VERSION_SUBMINOR])
82AC_CONFIG_FILES([src/microhttpd/microhttpd_dll_res.rc]) 82AC_CONFIG_FILES([src/microhttpd/microhttpd_dll_res.rc])
83 83
84AX_PTHREAD(,[AC_MSG_ERROR([[Compiling libmicrohttpd requires pthread support]])])
85LIBS="$PTHREAD_LIBS $LIBS"
86CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
87CC="$PTHREAD_CC"
88
84# set GCC options 89# set GCC options
85# use '-fno-strict-aliasing', but only if the compiler can take it 90# use '-fno-strict-aliasing', but only if the compiler can take it
86AX_APPEND_COMPILE_FLAGS([[-fno-strict-aliasing]]) 91AX_APPEND_COMPILE_FLAGS([[-fno-strict-aliasing]])
@@ -132,7 +137,6 @@ netbsd*)
132 AC_DEFINE_UNQUOTED(SOLARIS,1,[This is a Solaris system]) 137 AC_DEFINE_UNQUOTED(SOLARIS,1,[This is a Solaris system])
133 AC_DEFINE_UNQUOTED(_REENTRANT,1,[Need with solaris or errno doesnt work]) 138 AC_DEFINE_UNQUOTED(_REENTRANT,1,[Need with solaris or errno doesnt work])
134 AM_CONDITIONAL(HAVE_GNU_LD, false) 139 AM_CONDITIONAL(HAVE_GNU_LD, false)
135 LDFLAGS="$LDFLAGS -lpthread"
136 ;; 140 ;;
137*arm-linux*) 141*arm-linux*)
138 AC_DEFINE_UNQUOTED(LINUX,1,[This is a Linux kernel]) 142 AC_DEFINE_UNQUOTED(LINUX,1,[This is a Linux kernel])
@@ -232,12 +236,6 @@ fi
232AM_CONDITIONAL(ENABLE_EPOLL, [test "x$enable_epoll" != "xno"]) 236AM_CONDITIONAL(ENABLE_EPOLL, [test "x$enable_epoll" != "xno"])
233 237
234 238
235CHECK_PTHREAD
236LIBS="$PTHREAD_LIBS $LIBS"
237AC_SUBST(PTHREAD_LIBS)
238AC_SUBST(PTHREAD_LDFLAGS)
239AC_SUBST(PTHREAD_CPPFLAGS)
240
241# Check for headers that are ALWAYS required 239# Check for headers that are ALWAYS required
242AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files])) 240AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files]))
243 241