aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5292798a..1a0870b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -642,6 +642,28 @@ AM_CONDITIONAL(USE_MS_LIB_TOOL, [test "x$ac_cv_use_ms_lib_tool" = "xyes"])
642MHD_CHECK_SOCKET_SHUTDOWN_TRIGGER([AC_DEFINE([HAVE_LISTEN_SHUTDOWN],[1],[can use shutdown on listen sockets])]) 642MHD_CHECK_SOCKET_SHUTDOWN_TRIGGER([AC_DEFINE([HAVE_LISTEN_SHUTDOWN],[1],[can use shutdown on listen sockets])])
643AM_CONDITIONAL([HAVE_LISTEN_SHUTDOWN], [test "x$mhd_cv_host_shtdwn_trgr_select" = "xyes"]) 643AM_CONDITIONAL([HAVE_LISTEN_SHUTDOWN], [test "x$mhd_cv_host_shtdwn_trgr_select" = "xyes"])
644 644
645# SENDMSG. Should we check for SCM_RIGHTS instead?
646# https://lists.x.org/archives/xorg-devel/2013-November/038687.html
647AC_MSG_CHECKING([whether sendmsg is available])
648AC_SEARCH_LIBS(sendmsg, socket, AC_DEFINE([HAVE_SENDMSG],1,[Define if your platform supports sendmsg]))
649AC_MSG_CHECKING([whether writev is available])
650AC_CHECK_FUNCS([writev])
651
652# check MSG_MORE defined
653AC_MSG_CHECKING([whether MSG_MORE is defined])
654AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
655#include <sys/types.h>
656#include <sys/socket.h>
657]],[[return MSG_MORE;]]
658 )],
659 [
660 AC_MSG_RESULT(yes)
661 AC_DEFINE(HAVE_MSG_MORE, [1], [have MSG_MORE])
662 ],
663 [
664 AC_MSG_RESULT(no)
665 ])
666
645# set GCC options 667# set GCC options
646# use '-fno-strict-aliasing', but only if the compiler 668# use '-fno-strict-aliasing', but only if the compiler
647# and linker can take it 669# and linker can take it