aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 44 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 91e0a96e..6f2a7851 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,14 @@ AC_SUBST(LIB_VERSION_CURRENT)
34AC_SUBST(LIB_VERSION_REVISION) 34AC_SUBST(LIB_VERSION_REVISION)
35AC_SUBST(LIB_VERSION_AGE) 35AC_SUBST(LIB_VERSION_AGE)
36 36
37LIBSPDY_VERSION_CURRENT=0
38LIBSPDY_VERSION_REVISION=0
39LIBSPDY_VERSION_AGE=0
40AC_SUBST(LIBSPDY_VERSION_CURRENT)
41AC_SUBST(LIBSPDY_VERSION_REVISION)
42AC_SUBST(LIBSPDY_VERSION_AGE)
43
44
37if test `uname -s` = "OS/390" 45if test `uname -s` = "OS/390"
38then 46then
39# configure binaries for z/OS 47# configure binaries for z/OS
@@ -263,6 +271,39 @@ AC_CHECK_LIB(magic, magic_open,
263 AM_CONDITIONAL(HAVE_MAGIC, false))], 271 AM_CONDITIONAL(HAVE_MAGIC, false))],
264 AM_CONDITIONAL(HAVE_MAGIC, false)) 272 AM_CONDITIONAL(HAVE_MAGIC, false))
265 273
274
275# optional: libmicrospdy support. Enabled by default
276AC_MSG_CHECKING(whether to support libmicrospdy)
277AC_ARG_ENABLE([spdy],
278 AS_HELP_STRING([--disable-spdy],
279 [disable libmicrospdy]),
280 [enable_spdy=${enableval}],
281 [enable_spdy=yes])
282if test "$enable_spdy" = "yes"
283then
284 AC_DEFINE([SPDY_SUPPORT],[1],[include libmicrospdy support])
285else
286 AC_DEFINE([SPDY_SUPPORT],[0],[disable libmicrospdy support])
287fi
288AC_MSG_RESULT($enable_spdy)
289AM_CONDITIONAL(ENABLE_SPDY, [test "x$enable_spdy" != "xno"])
290
291spdy_OPENSSL
292# for pkg-config
293SPDY_LIBDEPS=""
294
295
296AC_SUBST(SPDY_LIB_LDFLAGS)
297# for pkg-config
298AC_SUBST(SPDY_LIBDEPS)
299
300AM_CONDITIONAL(ENABLE_MINITASN1, [test -n " " ] )
301AM_CONDITIONAL(ENABLE_OPENSSL, [test -n "" ] )
302AM_CONDITIONAL(HAVE_LD_OUTPUT_DEF, [test -n "" ] )
303AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, [test -n "" ] )
304
305
306
266LIBS=$SAVE_LIBS 307LIBS=$SAVE_LIBS
267AM_CONDITIONAL(HAVE_CURL, test x$curl = x1) 308AM_CONDITIONAL(HAVE_CURL, test x$curl = x1)
268 309
@@ -450,9 +491,12 @@ src/Makefile
450src/include/Makefile 491src/include/Makefile
451src/include/plibc/Makefile 492src/include/plibc/Makefile
452src/microhttpd/Makefile 493src/microhttpd/Makefile
494src/microspdy/Makefile
495src/spdy2http/Makefile
453src/examples/Makefile 496src/examples/Makefile
454src/testcurl/Makefile 497src/testcurl/Makefile
455src/testcurl/https/Makefile 498src/testcurl/https/Makefile
499src/testspdy/Makefile
456src/testzzuf/Makefile]) 500src/testzzuf/Makefile])
457AC_OUTPUT 501AC_OUTPUT
458 502