aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am58
1 files changed, 49 insertions, 9 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index c965d8a6..f6f01bb9 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -9,20 +9,32 @@ AM_CPPFLAGS = \
9 -I$(top_srcdir)/src/include \ 9 -I$(top_srcdir)/src/include \
10 @LIBGCRYPT_CFLAGS@ 10 @LIBGCRYPT_CFLAGS@
11 11
12AM_CFLAGS = -DDATADIR=\"$(top_srcdir)/src/datadir/\"
13
12if USE_COVERAGE 14if USE_COVERAGE
13 AM_CFLAGS = --coverage 15 AM_CFLAGS += --coverage
16endif
17
18if ENABLE_SPDY
19spdyex = \
20 spdy_event_loop \
21 spdy_fileserver \
22 spdy_response_with_callback
14endif 23endif
15 24
25
16# example programs 26# example programs
17noinst_PROGRAMS = \ 27noinst_PROGRAMS = \
18minimal_example \ 28 minimal_example \
19dual_stack_example \ 29 dual_stack_example \
20minimal_example_comet \ 30 minimal_example_comet \
21querystring_example \ 31 querystring_example \
22fileserver_example \ 32 fileserver_example \
23fileserver_example_dirs \ 33 fileserver_example_dirs \
24fileserver_example_external_select \ 34 fileserver_example_external_select \
25refuse_post_example 35 refuse_post_example \
36 $(spdyex)
37
26 38
27if ENABLE_HTTPS 39if ENABLE_HTTPS
28noinst_PROGRAMS += https_fileserver_example 40noinst_PROGRAMS += https_fileserver_example
@@ -116,3 +128,31 @@ https_fileserver_example_SOURCES = \
116https_fileserver_example.c 128https_fileserver_example.c
117https_fileserver_example_LDADD = \ 129https_fileserver_example_LDADD = \
118 $(top_builddir)/src/microhttpd/libmicrohttpd.la 130 $(top_builddir)/src/microhttpd/libmicrohttpd.la
131
132
133spdy_event_loop_SOURCES = \
134 spdy_event_loop.c
135spdy_event_loop_LDADD = \
136 $(top_builddir)/src/microspdy/libmicrospdy.la \
137 -lssl \
138 -lcrypto \
139 -lz \
140 -ldl
141
142spdy_fileserver_SOURCES = \
143 spdy_fileserver.c
144spdy_fileserver_LDADD = \
145 $(top_builddir)/src/microspdy/libmicrospdy.la \
146 -lssl \
147 -lcrypto \
148 -lz \
149 -ldl
150
151spdy_response_with_callback_SOURCES = \
152 spdy_response_with_callback.c
153spdy_response_with_callback_LDADD = \
154 $(top_builddir)/src/microspdy/libmicrospdy.la \
155 -lssl \
156 -lcrypto \
157 -lz \
158 -ldl