aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am34
1 files changed, 30 insertions, 4 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 7a484371..597a2d56 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -166,17 +166,17 @@ check_PROGRAMS = \
166if HAVE_POSIX_THREADS 166if HAVE_POSIX_THREADS
167if ENABLE_UPGRADE 167if ENABLE_UPGRADE
168if USE_POSIX_THREADS 168if USE_POSIX_THREADS
169 check_PROGRAMS += test_upgrade 169 check_PROGRAMS += test_upgrade test_upgrade_large
170endif 170endif
171if USE_W32_THREADS 171if USE_W32_THREADS
172 check_PROGRAMS += test_upgrade 172 check_PROGRAMS += test_upgrade test_upgrade_large
173endif 173endif
174if ENABLE_HTTPS 174if ENABLE_HTTPS
175if USE_POSIX_THREADS 175if USE_POSIX_THREADS
176check_PROGRAMS += test_upgrade_tls 176check_PROGRAMS += test_upgrade_tls test_upgrade_large_tls
177endif 177endif
178if USE_W32_THREADS 178if USE_W32_THREADS
179check_PROGRAMS += test_upgrade_tls 179check_PROGRAMS += test_upgrade_tls test_upgrade_large_tls
180endif 180endif
181endif 181endif
182endif 182endif
@@ -231,6 +231,19 @@ test_upgrade_LDADD = \
231 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \ 231 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
232 $(PTHREAD_LIBS) 232 $(PTHREAD_LIBS)
233 233
234test_upgrade_large_SOURCES = \
235 test_upgrade_large.c test_helpers.h mhd_sockets.h
236test_upgrade_large_CPPFLAGS = \
237 $(AM_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS)
238test_upgrade_large_CFLAGS = \
239 $(AM_CFLAGS) $(PTHREAD_CFLAGS) $(MHD_TLS_LIB_CFLAGS)
240test_upgrade_large_LDFLAGS = \
241 $(MHD_TLS_LIB_LDFLAGS)
242test_upgrade_large_LDADD = \
243 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
244 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
245 $(PTHREAD_LIBS)
246
234test_upgrade_tls_SOURCES = \ 247test_upgrade_tls_SOURCES = \
235 test_upgrade.c test_helpers.h mhd_sockets.h 248 test_upgrade.c test_helpers.h mhd_sockets.h
236test_upgrade_tls_CPPFLAGS = \ 249test_upgrade_tls_CPPFLAGS = \
@@ -244,6 +257,19 @@ test_upgrade_tls_LDADD = \
244 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \ 257 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
245 $(PTHREAD_LIBS) 258 $(PTHREAD_LIBS)
246 259
260test_upgrade_large_tls_SOURCES = \
261 test_upgrade_large.c test_helpers.h mhd_sockets.h
262test_upgrade_large_tls_CPPFLAGS = \
263 $(AM_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS)
264test_upgrade_large_tls_CFLAGS = \
265 $(AM_CFLAGS) $(PTHREAD_CFLAGS) $(MHD_TLS_LIB_CFLAGS)
266test_upgrade_large_tls_LDFLAGS = \
267 $(MHD_TLS_LIB_LDFLAGS)
268test_upgrade_large_tls_LDADD = \
269 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
270 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
271 $(PTHREAD_LIBS)
272
247test_postprocessor_SOURCES = \ 273test_postprocessor_SOURCES = \
248 test_postprocessor.c 274 test_postprocessor.c
249test_postprocessor_CPPFLAGS = \ 275test_postprocessor_CPPFLAGS = \