aboutsummaryrefslogtreecommitdiff
path: root/src/microspdy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microspdy/Makefile.am')
-rw-r--r--src/microspdy/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/microspdy/Makefile.am b/src/microspdy/Makefile.am
new file mode 100644
index 00000000..0509134a
--- /dev/null
+++ b/src/microspdy/Makefile.am
@@ -0,0 +1,38 @@
1if USE_PRIVATE_PLIBC_H
2 PLIBC_INCLUDE = -I$(top_srcdir)/src/include/plibc
3endif
4
5AM_CPPFLAGS = \
6 $(PLIBC_INCLUDE) \
7 -I$(top_srcdir)/src/include \
8 -I$(top_srcdir)/src/microspdy
9
10
11EXTRA_DIST = EXPORT.sym
12
13
14lib_LTLIBRARIES = \
15 libmicrospdy.la
16
17libmicrospdy_la_SOURCES = \
18 tls.h tls.c \
19 structures.h structures.c \
20 internal.h internal.c \
21 daemon.h daemon.c \
22 stream.h stream.c \
23 compression.h compression.c \
24 session.h session.c \
25 applicationlayer.c applicationlayer.h \
26 alstructures.c alstructures.h
27
28
29libmicrospdy_la_LDFLAGS = \
30 $(SPDY_LIB_LDFLAGS)
31
32libmicrospdy_la_CFLAGS = -Wextra \
33 $(SPDY_LIB_CFLAGS)
34
35
36if USE_COVERAGE
37 AM_CFLAGS = --coverage
38endif