aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 0 insertions, 30 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index dc4e4c4..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,30 +0,0 @@
1# This Makefile.am is in the public domain
2
3SUBDIRS = ui
4
5bin_PROGRAMS = messenger-cli
6
7messenger_cli_SOURCES = \
8 application.c application.h \
9 chat.c chat.h \
10 util.c util.h \
11 messenger_cli.c
12
13messenger_cli_LDADD = \
14 ui/libui.a
15
16messenger_cli_LDFLAGS = \
17 -lgnunetchat \
18 -lgnunetutil \
19 -lncurses
20
21messenger_cli_CFLAGS = \
22 -pedantic -Wall -Wextra -Wno-overlength-strings
23
24if DEBUG
25messenger_cli_CFLAGS += \
26 -O0 -D _DEBUG -ggdb3
27else
28messenger_cli_CFLAGS += \
29 -O2 -D NDEBUG
30endif