aboutsummaryrefslogtreecommitdiff
path: root/pathologist/src/mi/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-08-26 12:25:06 +0200
committerChristian Grothoff <christian@grothoff.org>2021-08-26 12:25:06 +0200
commit6bfc7b600b276d4a6c139cdb6b0335ed572332f5 (patch)
tree831f170cb424e30b49d0d20b4d97a0fb6df8ea65 /pathologist/src/mi/Makefile.am
downloadmonkey-6bfc7b600b276d4a6c139cdb6b0335ed572332f5.tar.gz
monkey-6bfc7b600b276d4a6c139cdb6b0335ed572332f5.zip
-recoveredHEADmaster
Diffstat (limited to 'pathologist/src/mi/Makefile.am')
-rw-r--r--pathologist/src/mi/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/pathologist/src/mi/Makefile.am b/pathologist/src/mi/Makefile.am
new file mode 100644
index 0000000..1248080
--- /dev/null
+++ b/pathologist/src/mi/Makefile.am
@@ -0,0 +1,29 @@
1INCLUDES = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12lib_LTLIBRARIES = libmi.la
13
14libmi_la_SOURCES = \
15 gdbmi_alloc.c \
16 gdbmi_breakpoint.c \
17 gdbmi_connect.c \
18 gdbmi_data_man.c \
19 gdbmi_error.c \
20 gdbmi_get_free_pty.c \
21 gdbmi_get_free_vt.c \
22 gdbmi_misc.c \
23 gdbmi_parse.c \
24 gdbmi_prg_control.c \
25 gdbmi_stack_man.c \
26 gdbmi_symbol_query.c \
27 gdbmi_target_man.c \
28 gdbmi_thread.c \
29 gdbmi_var_obj.c \ No newline at end of file