summaryrefslogtreecommitdiff
path: root/prototype_2016/third_party/fluid/tests/auto/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'prototype_2016/third_party/fluid/tests/auto/core/CMakeLists.txt')
-rw-r--r--prototype_2016/third_party/fluid/tests/auto/core/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/prototype_2016/third_party/fluid/tests/auto/core/CMakeLists.txt b/prototype_2016/third_party/fluid/tests/auto/core/CMakeLists.txt
new file mode 100644
index 0000000..dbe79a9
--- /dev/null
+++ b/prototype_2016/third_party/fluid/tests/auto/core/CMakeLists.txt
@@ -0,0 +1,10 @@
1set(SOURCES core.cpp)
2
3set(CMAKE_MACOSX_BUNDLE FALSE)
4
5add_definitions(-DQUICK_TEST_SOURCE_DIR="${CMAKE_CURRENT_SOURCE_DIR}")
6
7add_executable(tst_core ${SOURCES})
8target_link_libraries(tst_core Qt5::Qml Qt5::Test Qt5::QuickTest)
9add_test(tst_core tst_core)
10add_dependencies(check tst_core)