aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2006-04-05 06:11:59 +0000
committerChristian Grothoff <christian@grothoff.org>2006-04-05 06:11:59 +0000
commit3cf77a9cb18163d402cc01df527faf32245668c4 (patch)
treedc5f461b3c270e7d5bd178fc5fb83454d9249640 /configure.ac
parentb6f4c5d502bfa20aa8b0c1da81da326027dcf0a9 (diff)
downloadgnunet-gtk-3cf77a9cb18163d402cc01df527faf32245668c4.tar.gz
gnunet-gtk-3cf77a9cb18163d402cc01df527faf32245668c4.zip
Hi again.
Soo, adding libnotify support to gnunet-gtk :) Im guessing its not so cleanly done(depending on how you wish to structure it, but ill leave that up to the GNUnet developers ;)), but its rather small so you shouldn't have any trouble deciding if it should go in SVN or not) Im unsure about the configure-ac.diff, if it is the "right thing(TM)" (it works here with and without libnotify) would be nice to be able to disable it altogether. (i can't find a good autotool tutorial online) the small diffs are included in the attached file(three-diffs-libnotify.tar.gz). anyways, im of to bed, good night. /Nicklas Larsson
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f18a8c0d..291636b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,6 +228,18 @@ then
228 AC_MSG_ERROR([gnunet-gtk requires libextractor headers]) 228 AC_MSG_ERROR([gnunet-gtk requires libextractor headers])
229fi 229fi
230 230
231# libnotify
232LIBNOTIFY_REQUIRED=0.3.2
233PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $LIBNOTIFY_REQUIRED], libnotify=yes, libnotify=no)
234AC_SUBST([LIBNOTIFY_CFLAGS])
235AC_SUBST([LIBNOTIFY_LIBS])
236AM_CONDITIONAL([ENABLE_LIBNOTIFY],[test "x$libnotify" = "xyes"])
237if test "x$libnotify" != "xyes"; then
238 AC_MSG_WARN([Library requirements (libnotify >= $LIBNOTIFY_REQUIRED) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.])
239else
240 AC_MSG_NOTICE([** libnotify integration enabled])
241 AC_DEFINE(WITH_LIBNOTIFY, 1, [Define if libnotify is enabled])
242fi
231 243
232# We define the paths here, because MinGW/GCC expands paths 244# We define the paths here, because MinGW/GCC expands paths
233# passed through the command line ("-DDATADIR=..."). This would 245# passed through the command line ("-DDATADIR=..."). This would