aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f18a8c0d..291636b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,6 +228,18 @@ then
228 AC_MSG_ERROR([gnunet-gtk requires libextractor headers]) 228 AC_MSG_ERROR([gnunet-gtk requires libextractor headers])
229fi 229fi
230 230
231# libnotify
232LIBNOTIFY_REQUIRED=0.3.2
233PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $LIBNOTIFY_REQUIRED], libnotify=yes, libnotify=no)
234AC_SUBST([LIBNOTIFY_CFLAGS])
235AC_SUBST([LIBNOTIFY_LIBS])
236AM_CONDITIONAL([ENABLE_LIBNOTIFY],[test "x$libnotify" = "xyes"])
237if test "x$libnotify" != "xyes"; then
238 AC_MSG_WARN([Library requirements (libnotify >= $LIBNOTIFY_REQUIRED) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.])
239else
240 AC_MSG_NOTICE([** libnotify integration enabled])
241 AC_DEFINE(WITH_LIBNOTIFY, 1, [Define if libnotify is enabled])
242fi
231 243
232# We define the paths here, because MinGW/GCC expands paths 244# We define the paths here, because MinGW/GCC expands paths
233# passed through the command line ("-DDATADIR=..."). This would 245# passed through the command line ("-DDATADIR=..."). This would