aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-09-03 21:49:18 +0200
committerMaxime Devos <maximedevos@telenet.be>2022-09-03 21:50:07 +0200
commite36c5037395ec80ab402ecdd429a58ee78475828 (patch)
tree51e4bfa135f26bb5cc7645eaf3fcde536616bea0 /Makefile.am
parentfe4e23e24c891505fb36b02ce64bd8e53f4dd5c4 (diff)
downloadgnunet-scheme-e36c5037395ec80ab402ecdd429a58ee78475828.tar.gz
gnunet-scheme-e36c5037395ec80ab402ecdd429a58ee78475828.zip
Makefile.am: Enable --r7rs, for the r7rs-symbols.
The #{ ... }# syntax is apparently unportable, let's go for | ... | instead.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a9ebd4e..a4e5078 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -157,13 +157,16 @@ nobase_nodist_guilesiteccache_DATA = $(GOBJECTS)
157# in Guix does not have .scm files (but it does in Guile). 157# in Guix does not have .scm files (but it does in Guile).
158# XXX: Use the C locale for when Guile lacks 158# XXX: Use the C locale for when Guile lacks
159# <https://git.sv.gnu.org/cgit/guile.git/commit/?h=stable-2.0&id=e2c6bf3866d1186c60bacfbd4fe5037087ee5e3f>. 159# <https://git.sv.gnu.org/cgit/guile.git/commit/?h=stable-2.0&id=e2c6bf3866d1186c60bacfbd4fe5037087ee5e3f>.
160#
161# Use --r7rs to allow |foo bar| symbols, as #{foo bar}# is non-standard and
162# not portable to Racket Scheme.
160%.go: %.scm 163%.go: %.scm
161 $(AM_V_GUILEC)$(MKDIR_P) "`dirname "$@"`" ; \ 164 $(AM_V_GUILEC)$(MKDIR_P) "`dirname "$@"`" ; \
162 $(AM_V_P) && out=1 || out=- ; \ 165 $(AM_V_P) && out=1 || out=- ; \
163 LC_ALL=C \ 166 LC_ALL=C \
164 builddir="$(top_builddir)" \ 167 builddir="$(top_builddir)" \
165 GUILE_AUTO_COMPILE=0 \ 168 GUILE_AUTO_COMPILE=0 \
166 $(GUILD) compile -O2 --target="$(host)" \ 169 $(GUILD) compile -O2 --target="$(host)" --r7rs \
167 -L "$(top_srcdir)" \ 170 -L "$(top_srcdir)" \
168 -Wformat -Wunbound-variable -Warity-mismatch \ 171 -Wformat -Wunbound-variable -Warity-mismatch \
169 -o "$@" "$<" >&$$out 172 -o "$@" "$<" >&$$out