aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorxrs <xrs@mail36.net>2019-10-26 15:04:35 +0200
committerxrs <xrs@mail36.net>2019-10-26 15:04:35 +0200
commitda87f37eb0766b7c0cf1664cfbfbaf6d15ef20bc (patch)
tree09912e95b697c4207a0026b34554e4fa7b22451f /Makefile.am
parent99d9c81fc154e9196734be3c9f51f081859539ee (diff)
parent01f5a8120cc609782547fbcff27a0dc81d1129de (diff)
downloadgnunet-da87f37eb0766b7c0cf1664cfbfbaf6d15ef20bc.tar.gz
gnunet-da87f37eb0766b7c0cf1664cfbfbaf6d15ef20bc.zip
obsolete due to alpine policy
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d69dd3a82..579939b09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,3 +38,12 @@ docdir = $(datadir)/doc/gnunet/
38doc_DATA = COPYING README 38doc_DATA = COPYING README
39 39
40ACLOCAL_AMFLAGS = -I m4 40ACLOCAL_AMFLAGS = -I m4
41
42# TODO: better nesting.
43if HAVE_UNCRUSTIFY_BINARY
44pretty:
45 find $(top_srcdir) -type f -name '*.c' -or -name '*.h' -print0 | xargs -0 uncrustify -c $(top_srcdir)/contrib/uncrustify.cfg --replace --no-backup 2>&1 || true
46if HAVE_YAPF_BINARY
47 find $(top_srcdir) -type f -name '*.py' -or -name '*.py.in' -print0 | xargs -0 $(YAPF_BINARY) -i 2>&1 || true
48endif
49endif