aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-07-14 11:05:51 +0000
committerClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-07-14 11:05:51 +0000
commit09be1a7abdd1de923db98e0513ab50aa6c1ac98a (patch)
tree2ac9d26c53e60fbfd77a64258957833e174c709b /configure.ac
parent28edd46f0da55f0ba65d57473ef1b674f5f60221 (diff)
downloadgnunet-09be1a7abdd1de923db98e0513ab50aa6c1ac98a.tar.gz
gnunet-09be1a7abdd1de923db98e0513ab50aa6c1ac98a.zip
Integrating bluetooth plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b1fea6a2e..f703ea5e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -362,6 +362,18 @@ AC_RUN_IFELSE(
362AC_LANG_POP(C) 362AC_LANG_POP(C)
363fi # $build = $target 363fi # $build = $target
364 364
365# check for bluetooth library
366bluetooth=0
367AC_CHECK_LIB(bluetooth, ba2str, bluetooth=1, bluetooth=0)
368if test "$bluetooth" = 1
369then
370 AM_CONDITIONAL(HAVE_LIBBLUETOOTH, true)
371 AC_DEFINE([HAVE_LIBBLUETOOTH],[1],[Have bluetooth library])
372else
373 AM_CONDITIONAL(HAVE_LIBBLUETOOTH, false)
374fi
375
376
365# libcurl 377# libcurl
366LIBCURL_CHECK_CONFIG(,7.21.3,curl=1,curl=0) 378LIBCURL_CHECK_CONFIG(,7.21.3,curl=1,curl=0)
367if test "$curl" = 1 379if test "$curl" = 1
@@ -1367,6 +1379,12 @@ then
1367 AC_MSG_NOTICE([NOTICE: libcurl not found. http client support will not be compiled.]) 1379 AC_MSG_NOTICE([NOTICE: libcurl not found. http client support will not be compiled.])
1368fi 1380fi
1369 1381
1382# bluetooth
1383if test "x$bluetooth" = "x0"
1384then
1385 AC_MSG_NOTICE([NOTICE: bluetooth library not found. bluetooth support will not be compiled.])
1386fi
1387
1370#gnutls 1388#gnutls
1371if test x$gnutls != xtrue 1389if test x$gnutls != xtrue
1372then 1390then