aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-10-10 12:50:50 +0000
committerChristian Grothoff <christian@grothoff.org>2011-10-10 12:50:50 +0000
commit53d8c4ed4dacea3f308303d5cbda2214dca596be (patch)
tree0696f6a9bce99e79185d89d11eecf0eac7afddf2 /configure.ac
parent815a39088f8f33eece015c371cd4f3a9115f4cc8 (diff)
downloadgnunet-53d8c4ed4dacea3f308303d5cbda2214dca596be.tar.gz
gnunet-53d8c4ed4dacea3f308303d5cbda2214dca596be.zip
kill malicious flag, legacy protocol numbers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 243b4361c..a05964484 100644
--- a/configure.ac
+++ b/configure.ac
@@ -695,21 +695,6 @@ AC_ARG_ENABLE([experimental],
695AC_MSG_RESULT($enable_experimental) 695AC_MSG_RESULT($enable_experimental)
696AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 696AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
697 697
698# should malicious code be compiled (code used for testing with malicious peers)
699AC_MSG_CHECKING(whether to compile malicious code)
700AC_ARG_ENABLE([malicious],
701 [AS_HELP_STRING([--enable-malicious], [enable compiling malicious code (only for developers for testing)])],
702 [enable_malicious=${enableval}],
703 [enable_malicious=no])
704AC_MSG_RESULT($enable_malicious)
705AM_CONDITIONAL([HAVE_MALICIOUS], [test "x$enable_malicious" = "xyes"])
706if test "$enable_malicious" = "yes"
707then
708 AC_DEFINE([HAVE_MALICIOUS],[1],[include malicious code])
709else
710 AC_DEFINE([HAVE_MALICIOUS],[0],[disable malicious code])
711fi
712
713# should code be enabled that works around missing OS functionality on Windows? 698# should code be enabled that works around missing OS functionality on Windows?
714# used for test cases 699# used for test cases
715if test $build_target = "mingw" 700if test $build_target = "mingw"