aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-01 12:07:49 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-01 12:07:49 +0000
commit5bc254646f2683c22851ea82f2a9fe40b02f3f93 (patch)
tree76f6280a5a1b4a8c074b50c4a36da3b213bfa173 /configure.ac
parent733b4a4947f50dee6c570ea7f5fe11d4cee807a4 (diff)
downloadgnunet-5bc254646f2683c22851ea82f2a9fe40b02f3f93.tar.gz
gnunet-5bc254646f2683c22851ea82f2a9fe40b02f3f93.zip
-use test for libunistring from gnulib
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 2 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index e6e465435..b899d782e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -369,35 +369,8 @@ fi
369LIBS=$SAVE_LIBS 369LIBS=$SAVE_LIBS
370 370
371# test for libunistring 371# test for libunistring
372unistring=0 372gl_LIBUNISTRING
373AC_MSG_CHECKING(for libunistring) 373if test $HAVE_LIBUNISTRING != yes; then
374AC_ARG_WITH(unistring,
375 [ --with-unistring=PFX base of libunistring installation],
376 [AC_MSG_RESULT([$with_unistring])
377 case $with_unistring in
378 no)
379 ;;
380 yes)
381 AC_CHECK_HEADERS(unistr.h,
382 AC_CHECK_LIB([unistring], [u8_check],
383 unistring=1))
384 ;;
385 *)
386 LDFLAGS="-L$with_unistring/lib $LDFLAGS"
387 CPPFLAGS="-I$with_unistring/include $CPPFLAGS"
388 AC_CHECK_HEADERS(unistr.h,
389 AC_CHECK_LIB([unistring], [u8_check],
390 EXT_LIB_PATH="-L$with_unistring/lib $EXT_LIB_PATH"
391 unistring=1))
392 ;;
393 esac
394 ],
395 [AC_MSG_RESULT([--with-unistring not specified])
396 AC_CHECK_HEADERS(unistr.h,
397 AC_CHECK_LIB([unistring], [u8_check],
398 unistring=1))])
399if test "$unistring" != 1
400then
401 AC_MSG_ERROR([GNUnet requires libunistring]) 374 AC_MSG_ERROR([GNUnet requires libunistring])
402fi 375fi
403# restore LIBS 376# restore LIBS