aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-09-25 21:35:32 +0900
committerMartin Schanzenbach <schanzen@gnunet.org>2022-09-25 21:35:32 +0900
commit82a7bd8af34060d352348241e139dbcd775311f5 (patch)
tree08faa268f64ed3b186fb8ab691f97f8b8729eeac /configure.ac
parent622cfef5af42da1c283bc9c0a0423e18e20d5c53 (diff)
downloadgnunet-82a7bd8af34060d352348241e139dbcd775311f5.tar.gz
gnunet-82a7bd8af34060d352348241e139dbcd775311f5.zip
DOC: Conditionally build doxygen; build sphinx on bootstrap
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 7 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index f24ca77b2..bfaff3280 100644
--- a/configure.ac
+++ b/configure.ac
@@ -442,15 +442,10 @@ AC_ARG_ENABLE([documentation],
442 [documentation=${enableval}], 442 [documentation=${enableval}],
443 [documentation=yes]) 443 [documentation=yes])
444 444
445AC_CHECK_PROG([SPHINX_BINARY], [sphinx-build], [true], [false]) 445AC_CHECK_PROG([DOXY_BINARY], [doxygen], [true], [false])
446AM_CONDITIONAL([HAVE_SPHINX_BINARY], [$SPHINX_BINARY]) 446AM_CONDITIONAL([HAVE_DOXY_BINARY], [$DOXY_BINARY])
447 447
448AM_CONDITIONAL([DOCUMENTATION], [test "x$documentation" = "xyes"]) 448AM_CONDITIONAL([DOCUMENTATION], [test "x$documentation" = "xyes"])
449AS_IF([test "x$documentation" = "xyes"],
450 [AS_IF([$SPHINX_BINARY],
451 [AC_DEFINE([DOCUMENTATION], [1], [Define to 1 if documentation is built])],
452 [AC_MSG_ERROR([Documentation requires sphinx])])],
453 [AC_DEFINE([DOCUMENTATION], [0], [Define to 1 if documentation is built])])
454 449
455AC_CHECK_PROGS([MANDOC_BINARY], [mandoc], [false]) 450AC_CHECK_PROGS([MANDOC_BINARY], [mandoc], [false])
456AM_CONDITIONAL([HAVE_MANDOC], [test "x$MANDOC_BINARY" != "xfalse"]) 451AM_CONDITIONAL([HAVE_MANDOC], [test "x$MANDOC_BINARY" != "xfalse"])
@@ -1458,10 +1453,10 @@ AS_IF([test "x$MANDOC_BINARY" = "xfalse"],
1458 [mandoc_msg="no"], 1453 [mandoc_msg="no"],
1459 [mandoc_msg="yes"]) 1454 [mandoc_msg="yes"])
1460 1455
1461# sphinx 1456# doxy
1462AS_IF([test "x$documentation" = "xyes"], 1457AS_IF([$DOXY_BINARY],
1463 [sphinx_msg="yes"], 1458 [doxy_msg="yes"],
1464 [sphinx_msg="no"]) 1459 [doxy_msg="no"])
1465 1460
1466# conversation 1461# conversation
1467conversation_msg="no" 1462conversation_msg="no"
@@ -1605,7 +1600,7 @@ gstreamer: ${gstreamer_msg}
1605 1600
1606Java: ${java_msg} 1601Java: ${java_msg}
1607 1602
1608sphinx: ${sphinx_msg} 1603doxygen: ${doxy_msg}
1609mandoc: ${mandoc_msg} 1604mandoc: ${mandoc_msg}
1610 1605
1611GNUnet configuration 1606GNUnet configuration