aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-08-31 19:21:03 +0000
committerChristian Grothoff <christian@grothoff.org>2013-08-31 19:21:03 +0000
commit9839451a4a8344322d6a1578540e2eb1919427d7 (patch)
tree9b3073727d059805ac94598a78a13d309111d8cf /configure.ac
parent7d8f30700625ba1a94cbdb66362d92943a447412 (diff)
downloadgnunet-9839451a4a8344322d6a1578540e2eb1919427d7.tar.gz
gnunet-9839451a4a8344322d6a1578540e2eb1919427d7.zip
trying to fix #3006, libltdl detection on FreeBSD
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac41
1 files changed, 35 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 1810bc01e..2a6a8a8ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,10 +43,6 @@ AC_PROG_LN_S
43AC_PROG_MAKE_SET 43AC_PROG_MAKE_SET
44AM_PROG_CC_C_O 44AM_PROG_CC_C_O
45LT_INIT([disable-static dlopen win32-dll]) 45LT_INIT([disable-static dlopen win32-dll])
46LT_CONFIG_LTDL_DIR([libltdl])
47LTDL_INIT
48AC_SUBST(LTDLINCL)
49AC_SUBST(LIBLTDL)
50AC_SUBST(MKDIR_P) 46AC_SUBST(MKDIR_P)
51 47
52# large file support 48# large file support
@@ -473,6 +469,41 @@ fi
473# restore LIBS 469# restore LIBS
474LIBS=$SAVE_LIBS 470LIBS=$SAVE_LIBS
475 471
472# Check for libltdl header (#2999)
473ltdl=0
474AC_MSG_CHECKING(for libltdl)
475AC_ARG_WITH(ltdl,
476 [ --with-ltdl=PFX base of libltdl installation],
477 [AC_MSG_RESULT([$with_ltdl])
478 case $with_ltdl in
479 no)
480 ;;
481 yes)
482 AC_CHECK_HEADERS(ltdl.h,
483 AC_CHECK_LIB([ltdl], [lt_dlopenext],
484 ltdl=1))
485 ;;
486 *)
487 LDFLAGS="-L$with_ltdl/lib $LDFLAGS"
488 CPPFLAGS="-I$with_ltdl/include $CPPFLAGS"
489 AC_CHECK_HEADERS(ltdl.h,
490 AC_CHECK_LIB([ltdl], [lt_dlopenext],
491 EXT_LIB_PATH="-L$with_ltdl/lib $EXT_LIB_PATH"
492 ltdl=1))
493 ;;
494 esac
495 ],
496 [AC_MSG_RESULT([--with-ltdl not specified])
497 AC_CHECK_HEADERS(ltdl.h,
498 AC_CHECK_LIB([ltdl], [lt_dlopenext],
499 ltdl=1))])
500if test "$ltdl" != 1
501then
502 AC_MSG_ERROR([GNUnet requires libltdl (from GNU libtool), try installing libltdl-dev])
503fi
504# restore LIBS
505LIBS=$SAVE_LIBS
506
476# test for libunistring 507# test for libunistring
477gl_LIBUNISTRING 508gl_LIBUNISTRING
478if test $HAVE_LIBUNISTRING != yes; then 509if test $HAVE_LIBUNISTRING != yes; then
@@ -494,8 +525,6 @@ AC_HEADER_STDC
494AC_CHECK_HEADERS([fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h string.h unistd.h stdarg.h signal.h locale.h sys/stat.h sys/types.h],,AC_MSG_ERROR([Compiling GNUnet requires standard UNIX headers files])) 525AC_CHECK_HEADERS([fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h string.h unistd.h stdarg.h signal.h locale.h sys/stat.h sys/types.h],,AC_MSG_ERROR([Compiling GNUnet requires standard UNIX headers files]))
495 526
496 527
497# Check for libltdl header (#2999)
498AC_CHECK_HEADERS([ltdl.h],,AC_MSG_ERROR([Compiling GNUnet requires libltdl headers (try installing libltdl-dev)]))
499 528
500# Checks for headers that are only required on some systems or opional (and where we do NOT abort if they are not there) 529# Checks for headers that are only required on some systems or opional (and where we do NOT abort if they are not there)
501AC_CHECK_HEADERS([malloc.h malloc/malloc.h langinfo.h sys/param.h sys/mount.h sys/statvfs.h sys/select.h sockLib.h sys/mman.h sys/msg.h sys/vfs.h arpa/inet.h fcntl.h libintl.h netdb.h netinet/in.h netinet/in_systm.h netinet/ip.h sys/ioctl.h sys/socket.h sys/time.h unistd.h kstat.h sys/sysinfo.h kvm.h sys/file.h sys/resource.h ifaddrs.h mach/mach.h stddef.h sys/timeb.h terminos.h argz.h ucred.h endian.h sys/endian.h execinfo.h]) 530AC_CHECK_HEADERS([malloc.h malloc/malloc.h langinfo.h sys/param.h sys/mount.h sys/statvfs.h sys/select.h sockLib.h sys/mman.h sys/msg.h sys/vfs.h arpa/inet.h fcntl.h libintl.h netdb.h netinet/in.h netinet/in_systm.h netinet/ip.h sys/ioctl.h sys/socket.h sys/time.h unistd.h kstat.h sys/sysinfo.h kvm.h sys/file.h sys/resource.h ifaddrs.h mach/mach.h stddef.h sys/timeb.h terminos.h argz.h ucred.h endian.h sys/endian.h execinfo.h])