aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-06-01 13:21:31 +0000
committerChristian Grothoff <christian@grothoff.org>2015-06-01 13:21:31 +0000
commita2417d5b3fc632fb1bacca6594c50a0ef7ffd23a (patch)
tree97f4ad1be176e5883fd7357af5b5a167b8df969c /configure.ac
parentb77b46e3c7b531460391ce8e04098084cb81b829 (diff)
downloadgnunet-a2417d5b3fc632fb1bacca6594c50a0ef7ffd23a.tar.gz
gnunet-a2417d5b3fc632fb1bacca6594c50a0ef7ffd23a.zip
more fixes on #3805
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 73c557e5b..3072684fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -365,7 +365,8 @@ AC_RUN_IFELSE(
365 then 365 then
366 AC_MSG_FAILURE([libgcrypt header version does not match library version]) 366 AC_MSG_FAILURE([libgcrypt header version does not match library version])
367 fi 367 fi
368 ]) 368 ],
369 [AC_MSG_RESULT([cross compiling, test skipped])])
369AC_LANG_POP(C) 370AC_LANG_POP(C)
370fi # $build = $target 371fi # $build = $target
371 372
@@ -812,13 +813,14 @@ AC_ARG_ENABLE(mysql-version-check, [ --disable-mysql-version-check do not chec
812if test "$mysql" = "true" -a "x$enable_mysql_version_check" = "xyes" 813if test "$mysql" = "true" -a "x$enable_mysql_version_check" = "xyes"
813then 814then
814 AC_MSG_CHECKING(mysql version) 815 AC_MSG_CHECKING(mysql version)
815 AC_RUN_IFELSE([AC_LANG_PROGRAM( 816 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
816 [[$CYGWIN_MYSQL_MAGIC 817 [[$CYGWIN_MYSQL_MAGIC
817 #include <mysql/mysql.h>]], 818 #include <mysql/mysql.h>]],
818 [[if (MYSQL_VERSION_ID < 40100) 819 [[
819 return(-1); 820 #if (MYSQL_VERSION_ID < 40100)
820 else 821 #error needs at least version >= 4.1
821 return(0); 822 #endif
823 int main () { return 0; }
822 ]]) 824 ]])
823 ],mysql=true,mysql=false) 825 ],mysql=true,mysql=false)
824 if test "$mysql" = "false" 826 if test "$mysql" = "false"
@@ -900,16 +902,16 @@ AC_ARG_WITH(microhttpd,
900 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT, 902 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
901 AC_CHECK_LIB([microhttpd], [MHD_get_fdset2], 903 AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
902 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32]) 904 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
903 AC_RUN_IFELSE([AC_LANG_SOURCE([ 905 AC_COMPILE_IFELSE([AC_LANG_SOURCE([
904 #include "$native_srcdir/src/include/platform.h" 906 #include "$native_srcdir/src/include/platform.h"
905 #include <microhttpd.h> 907 #include <microhttpd.h>
906 int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; } 908 #if (MHD_VERSION < 0x0093200)
909 #error needs at least version 0.9.32
910 #endif
907 ])], 911 ])],
908 [AC_MSG_RESULT(ok) 912 [AC_MSG_RESULT(ok)
909 lmhd=1], 913 lmhd=1],
910 [AC_MSG_RESULT(failed)], 914 [AC_MSG_RESULT(failed)])]),
911 [AC_MSG_RESULT(cross-compiling, assuming OK)
912 lmhd=1])]),
913 [],[#include "$native_srcdir/src/include/platform.h" 915 [],[#include "$native_srcdir/src/include/platform.h"
914 #include <microhttpd.h>]),, 916 #include <microhttpd.h>]),,
915 [#include "$native_srcdir/src/include/platform.h"])]) 917 [#include "$native_srcdir/src/include/platform.h"])])