summaryrefslogtreecommitdiff
path: root/contrib/guix/gnu/packages
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2018-08-17 01:34:12 +0200
committerFlorian Dold <florian.dold@gmail.com>2018-08-17 01:34:12 +0200
commitbaa1a0165ca3662a9e247e562205208f12df6c8b (patch)
treea160a3d93c6876cc56eed75f5629d665e8e4d9a6 /contrib/guix/gnu/packages
parent333a708e1a4d95851be3bee5bf66bb15684b6948 (diff)
guix: fix git filter and source-dir
Diffstat (limited to 'contrib/guix/gnu/packages')
-rw-r--r--contrib/guix/gnu/packages/gnunet.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/contrib/guix/gnu/packages/gnunet.scm b/contrib/guix/gnu/packages/gnunet.scm
index 3a1943757..a91c69a11 100644
--- a/contrib/guix/gnu/packages/gnunet.scm
+++ b/contrib/guix/gnu/packages/gnunet.scm
@@ -245,8 +245,14 @@ supports HTTP, HTTPS and GnuTLS.")
"See COPYING in the distribution."))
(home-page "https://gnunet.org/gnurl")))
-(define %source-dir (dirname (current-filename)))
+(define (repeat f n)
+ (if (= n 1)
+ f
+ (lambda (x) (f ((repeat f (- n 1)) x)))))
+
+(define %source-dir ((repeat dirname 5) (current-filename)))
+
(define (git-output . args)
"Execute 'git ARGS ...' command and return its output without trailing
newspace."
@@ -260,7 +266,7 @@ newspace."
(git-output "describe" "--tags"))
(define (git-sources)
- (local-file (dirname (dirname (dirname (dirname %source-dir))))
+ (local-file %source-dir
#:recursive? #t
#:select? (git-predicate %source-dir)))